This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
openCPN crashing
#1
I have posted to openCPN on cruisers forum as well as github with no response. Here is my problem:

New to linux and rasberry pi. I have a pi 5 running open plotter 4. mccarthur hat and daisy hat running ais and a gps dongle.
opencpn was running fine before i started integrating data from signal k (2.7.1). After this it crashes immediately on start up from the openplotter desktop. I have tried moving the data folder for opencpn, disabling plug ins for opencpn and signalk, as well as turning off openGL. Nothing changes the issue. I can run it under sudo from a terminal and everything seems to run fine. Here is the log and config files for opencpn


LOG:
872 MESSAGE waypointman_gui.cpp:68 Loading UserIcons from /root/.opencpn/UserIcons/
12:06:56.872 MESSAGE navutil.cpp:1694 Loading navobjects from navobj.xml
12:06:56.872 MESSAGE navutil.cpp:1705 Done loading navobjects, 0 duplicate waypoints ignored
12:06:56.872 MESSAGE ocpn_frame.cpp:4834 Getting .gpx layer files from: /root/.opencpn/layers
12:06:57.021 MESSAGE ocpn_frame.cpp:4739 OnInitTimer...1
12:06:57.021 MESSAGE comm_drv_factory.cpp:54 MakeCommDriver: Serial:/dev/ttyOP_daisyh
12:06:57.021 MESSAGE comm_drv_factory.cpp:54 MakeCommDriver: Signal K:localhost:3000
12:06:57.021 MESSAGE comm_drv_signalk_net.cpp:275 Opening Signal K WebSocket client: Signal K:localhost:3000
12:06:57.022 MESSAGE comm_drv_factory.cpp:54 MakeCommDriver: Serial:/dev/ttyOP_gps
12:06:57.093 MESSAGE comm_drv_signalk_net.cpp:357 Connected to Signal K server version: 2.7.1
12:06:57.157 MESSAGE ocpn_frame.cpp:4739 OnInitTimer...2
12:06:57.157 MESSAGE plugin_loader.cpp:246 PluginLoader: loading plugins from /root/.local/lib/opencpn;/usr/lib/opencpn
12:06:57.157 MESSAGE plugin_loader.cpp:162 Using LD_LIBRARY_PATH: /root/.local/lib/opencpn:/usr/lib/opencpn
12:06:57.157 MESSAGE plugin_loader.cpp:194 Using PATH: /root/.local/bin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
12:06:57.157 MESSAGE plugin_loader.cpp:251 Loading plugins from dir: /root/.local/lib/opencpn
12:06:57.157 MESSAGE plugin_loader.cpp:444 PluginLoader searching for PlugIns in location /root/.local/lib/opencpn
12:06:57.157 MESSAGE plugin_loader.cpp:458 Directory /root/.local/lib/opencpn does not exist.
12:06:57.157 MESSAGE plugin_loader.cpp:251 Loading plugins from dir: /usr/lib/opencpn
12:06:57.157 MESSAGE plugin_loader.cpp:444 PluginLoader searching for PlugIns in location /usr/lib/opencpn
12:06:57.157 MESSAGE plugin_loader.cpp:458 Directory /usr/lib/opencpn does not exist.
12:06:57.165 MESSAGE glChartCanvas.cpp:554 BuildFBO 3
12:06:57.165 MESSAGE glChartCanvas.cpp:1009 OpenGL-> Framebuffer OK, size = 1918
12:06:57.271 MESSAGE OCPNPlatform.cpp:1006 ChangeLocale: Language load for: en_US
12:06:57.272 MESSAGE OCPNPlatform.cpp:1059 ChangeLocale: Locale Init OK for: en_US
12:06:57.272 MESSAGE OCPNPlatform.cpp:1084 Loading catalog for opencpn core.
12:06:57.272 MESSAGE OCPNPlatform.cpp:925 Getting DefaultSystemLocale...
12:06:57.335 MESSAGE ocpn_frame.cpp:4739 OnInitTimer...3
12:06:57.474 MESSAGE ocpn_frame.cpp:4739 OnInitTimer...4
12:06:57.534 MESSAGE OCPNPlatform.cpp:823 Starting OpenGL test...
12:06:57.655 MESSAGE OCPNPlatform.cpp:829 OpenGL test complete.
12:06:57.655 MESSAGE OCPNPlatform.cpp:850 OpenGL determined CAPABLE.
12:06:57.661 MESSAGE OCPNPlatform.cpp:823 Starting OpenGL test...
12:06:57.664 MESSAGE OCPNPlatform.cpp:829 OpenGL test complete.
12:06:57.664 MESSAGE OCPNPlatform.cpp:850 OpenGL determined CAPABLE.
12:06:58.108 MESSAGE options.cpp:5348 options: got device count: 4
12:06:58.259 MESSAGE ocpn_frame.cpp:4739 OnInitTimer...5
12:06:58.360 MESSAGE ocpn_frame.cpp:4739 OnInitTimer...6
12:06:58.461 MESSAGE ocpn_frame.cpp:4739 OnInitTimer...7
12:06:58.461 MESSAGE ocpn_frame.cpp:5025 OnInitTimer...Last Call
12:06:58.461 MESSAGE ocpn_frame.cpp:5043 OnInitTimer...Finalize Canvases
12:06:58.477 MESSAGE glChartCanvas.cpp:554 BuildFBO 3
12:06:58.477 MESSAGE glChartCanvas.cpp:1009 OpenGL-> Framebuffer OK, size = 1918
12:06:58.504 MESSAGE glChartCanvas.cpp:554 BuildFBO 3
12:06:58.504 MESSAGE glChartCanvas.cpp:1009 OpenGL-> Framebuffer OK, size = 1918
12:06:58.732 MESSAGE chartdb.cpp:1169 Creating new chart
12:06:58.732 MESSAGE chartdb.cpp:1286 Initializing Chart /home/Big_Time_Brendo/Documents/Charts/ENC/US_OR/US5OR43M/US5OR43M.000
12:06:58.733 MESSAGE s57chart.cpp:2713 S57chart::Checking SENC file: /root/.opencpn/SENC/2556420DB639_US5OR43M.S57
12:07:02.307 ERROR htmlwin.cpp:586 Unable to open requested HTML document: file:///usr/share/opencpn/authors.html
12:07:55.336 MESSAGE ocpn_frame.cpp:5641 LOGBOOK: 2024-04-15 19:07:55 UTC GPS Lat 44.65556 Lon -123.11512 COG 347.27000 SOG 0.20 kts


CONFIG:
S57DataLocation=
InitChartDir=/home/Big_Time_Brendo/Documents/Charts/ENC
GPXIODir=
TCDataDir=
BasemapDir=/usr/share/opencpn/gshhs/
pluginInstallDir=
[Canvas]
CanvasConfig=0
[Canvas/CanvasConfig1]
canvasVPLatLon=" 44.6229, -124.0509"
canvasVPScale=0.904375
canvasVPRotation=0
canvasInitialdBIndex=26
canvasbFollow=0
ActiveChartGroup=0
canvasToolbarConfig=
canvasShowToolbar=0
canvasQuilt=1
canvasShowGrid=0
canvasShowOutlines=1
canvasShowDepthUnits=1
canvasShowAIS=1
canvasAttenAIS=0
canvasShowTides=0
canvasShowCurrents=0
canvasShowENCText=1
canvasENCDisplayCategory=83
canvasENCShowDepths=1
canvasENCShowBuoyLabels=1
canvasENCShowLightDescriptions=0
canvasENCShowLights=1
canvasENCShowVisibleSectorLights=1
canvasENCShowAnchorInfo=0
canvasENCShowDataQuality=0
canvasCourseUp=0
canvasHeadUp=0
canvasLookahead=0
canvasSizeX=1918
canvasSizeY=986
[ChartDirectories]
ChartDir1=/home/Big_Time_Brendo/Documents/Charts/ENC/US_OR^5169477463940372518
ChartDir2=/home/Big_Time_Brendo/Documents/Charts/ENC/US_WA^2926934107275196095
[AUI]
AUIPerspective=layout2|name=ChartCanvas;caption=;state=768;dir=5;layer=0;row=0;pos=0;prop=100000;bestw=1918;besth=986;minw=384;minh=988;maxw=-1;maxh=-1;floatx=-1;floaty=-1;floatw=-1;floath=-1|dock_size(5,0,0)=386|
[TideCurrentDataSources]
tcds0=/usr/share/opencpn/tcdata/harmonics-dwf-20210110-free.tcd
tcds1=/usr/share/opencpn/tcdata/HARMONICS_NO_US.IDX

01
Reply
#2
Running opencpn as sudo works because the conf file does not exists for that user and the offending setting is not there yet.

I would try to start from scratch removing the folder /home/pi/.opencpn (you will delete all your settings). Then start adding settings until you get the crash. Do not run opencpn as sudo. Open a terminal an type opencpn instead of running from the desktop and paste here what the terminal says when crashing.

Are you using X11 or Wayland? opencpn is installed from backports or from flatpak?
Reply
#3
(Yesterday, 07:27 PM)Sailoog Wrote: Running opencpn as sudo works because the conf file does not exists for that user and the offending setting is not there yet.

I would try to start from scratch removing the folder /home/pi/.opencpn (you will delete all your settings). Then start adding settings until you get the crash. Do not run opencpn as sudo. Open a terminal an type opencpn instead of running from the desktop and paste here what the terminal says when crashing.

Are you using X11 or Wayland? opencpn is installed from backports or from flatpak?

when i search the file manager or search via terminal /home/pi/.opencpn there is "no such file or directory". I also searched in usr and lib with same result. If I can not find or delete the settings file, how can i get into the crashing opencpn to manipulate settings? I could try to delete opencpn completely from the "add/remove software" and reinstall? 
I am using X11. Installed opencpn from backports. 

HERE IS TERMINAL READ when launching opencpn from terminal:
No Connect
Unable to connect to 0.0.0.0:2947
No Connect
Unable to connect to 0.0.0.0:2947
No Connect
Unable to connect to 0.0.0.0:2947Segmentation fault
Big_Time_Brendo@rasputin:~ $ 



HERE IS TERMINAL READ launching FROM SUDO:

ALSA lib pcm_dmix.c:1011Sadsnd_pcm_dmix_open) unable to initialize slave
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
14:07:57: Debug: Device: 0: vc4-hdmi-0: MAI PCM i2s-hifi-0 (hw:0,0)
14:07:57: Debug: Device: 1: sysdefault
14:07:57: Debug: Device: 2: hdmi
14:07:57: Debug: Device: 3: default
14:07:57: Debug: Device: 0: vc4-hdmi-0: MAI PCM i2s-hifi-0 (hw:0,0)
14:07:57: Debug: Device: 1: sysdefault
14:07:57: Debug: Device: 2: hdmi
14:07:57: Debug: Device: 3: default
14:07:57: Debug: Device: 0: vc4-hdmi-0: MAI PCM i2s-hifi-0 (hw:0,0)
14:07:57: Debug: Device: 1: sysdefault
14:07:57: Debug: Device: 2: hdmi
14:07:57: Debug: Device: 3: default
14:07:57: Debug: Device: 0: vc4-hdmi-0: MAI PCM i2s-hifi-0 (hw:0,0)
14:07:57: Debug: Device: 1: sysdefault
14:07:57: Debug: Device: 2: hdmi
14:07:57: Debug: Device: 3: default
error: XDG_RUNTIME_DIR is invalid or not set in the environment.
*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug

GLEW init success!n SENC: nCPU: 4    m_max_jobs :3
Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal
error: XDG_RUNTIME_DIR is invalid or not set in the environment.
error: XDG_RUNTIME_DIR is invalid or not set in the environment.
Could not determine the accessibility bus address
error: XDG_RUNTIME_DIR is invalid or not set in the environment.

THANK YOU!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)