This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I would like to be able to install OP4 from scratch on RPi5 (Not using an image file)
#11
(2024-07-10, 06:14 PM)KKempeneers Wrote: Yeah maybe, I liked OP2 skipped OP3, wanted to try a new installation of OP4. But I seem to be missing an important part of the design philosophy. Why people want to write software that is soo depending on related modules is beyond me.
From that point of view OP4 is not very different from B&G. I can't scale neither of them to my needs.
I'll try again tomorrow on a RPi4, i suspect OP4 is not quite ready for RPi5.
Thanks for your advice.

I may not understand what "related modules" are but no changes here from OP2 and OP3, just updated modules.

I think your case is the typical case in which a user with some experience makes manual and imaginative changes expecting a system to be more difficult than it really is Smile
Reply
#12
Hi Sailoog,

I installed the latest up to date version of Raspberry-pi OS that is Debian Bookworm. I tried downloading the starter img to. Currently I'm working with the image on a PI4. I still have warnings regarding the credentials for notifications. (However no request is sent, I do not see a request for Notifications signalK access in SignalK)
Before that i had a go with the installation of the starter img on a PI5. (I teach computer science so have a lot of different PI's handy) That installation went oké. Except for the UART's 2 and 4 not showing op in Serial after they have been enabled, and the PI had rebooted.
It is possible that I tried the V3.x.x settings deb file first. When I'm back at my desk i will certainly verify that.
i would however really prefer to use the PI5. 

Koen.
Reply
#13
OP4 no longer sends connection requests to SK server because everything is automatic now and you have to do nothing to connect apps to the server. If you see those warning it means that you have another problem.

Your other issue with UART is also very strange. We have 40-50 daily downloads of the image files and most of them are being installed in RPi5. No one else reported that and I can not reproduce it, so we have to find out what is wrong in your system or what extra step or mistake are you doing.

If you agree we could focus on OP4 and RPI5. Pay attention to this check list:

- Be sure you are downloading this file: https://cloud.openmarine.net/s/TwxS4AJrt...le-img.zip

- DO NOT change the username or any setting during SD creation or after.

- DO NOT run openplotter apps as sudo.

- Update the system with sudo apt full-upgrade

- Run all the updated openplotter apps at least once

- Make sure you are not in Rescue mode: https://openplotter.readthedocs.io/lates...tml#rescue

- DO NOT perform any additional steps that are not in the current manual: https://openplotter.readthedocs.io/4.x.x/index.html

- If everything works try to repeat the installtion using the deb file instead of the image: https://openplotter.readthedocs.io/4.x.x...and-laptop

Let us know how it went.
Reply
#14
Quote:DO NOT change the username or any setting during SD creation or after.

So, that is what went wrong ... I have this little script that changes credentials, wifi settings and the username while burning the image. When I'm back at my desk I'll run a new img install for my PI5 I will get back to you with the results.

Thanks for the insights.
Reply
#15
There are warnings everywhere in the documentation about not changing the username on preconfigured Openplotter images for obvious reasons. You omitted this script in all your threads asking for help and it is impossible to help you if you hide the most important part.
Reply
#16
Sorry, but I seem to have missed that warning everywhere maybe use capitals next to the img download link?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)