This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Upgraded to 14 - no openplotter!
#11
yup, also loving the new calibration! Also the scope is great. My 9250 IMU shows a few degrees of variation of the heading over time.
Is this better with the 9255?
Reply
#12
updated same as others
command line output

No IMU detected
No pressure sensor detected
No humidity sensor detected
Traceback (most recent call last):
File "/home/pi/.config/openplotter/openplotter", line 3503, in <module>
MainFrame().Show()
File "/home/pi/.config/openplotter/openplotter", line 268, in __init__
self.read_compass()
File "/home/pi/.config/openplotter/openplotter", line 1249, in read_compass
self.detected.SetLabel(imu_name)
File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py", line 9207, in SetLabel
return _core_.Window_SetLabel(*args, **kwargs)
TypeError: String or Unicode type required
mare liberum
Reply
#13
Exact same problem (with the I2C section cleared as per your previous post)

pi@openplotter:~ $ openplotter
No IMU detected
No humidity sensor detected
Traceback (most recent call last):
 File "/home/pi/.config/openplotter/openplotter", line 3503, in <module>
   MainFrame().Show()
 File "/home/pi/.config/openplotter/openplotter", line 268, in __init__
   self.read_compass()
 File "/home/pi/.config/openplotter/openplotter", line 1249, in read_compass
   self.detected.SetLabel(imu_name)
 File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py", line 9207, in SetLabel
   return _core_.Window_SetLabel(*args, **kwargs)
TypeError: String or Unicode type required


BTW, upgrades still kill any user generated files (in my case BMV700.py, a driver to take data from the BMV-700 SOC battery monitor and sending the output to signalK)
Reply
#14
No update happens after this.. seems i have to reinstall complete new



pi@openplotter:~/.config/openplotter/update $ sudo su
root@openplotter:/home/pi/.config/openplotter/update# ./update_OpenPlotter.sh
bash: ./update_OpenPlotter.sh: Keine Berechtigung
root@openplotter:/home/pi/.config/openplotter/update# chmod 775 update_OpenPlotter.sh
root@openplotter:/home/pi/.config/openplotter/update# ./update_OpenPlotter.sh

DOWNLOADING NEW OPENPLOTTER CODE...

./update_OpenPlotter.sh: Zeile 12: [: =: Einstelliger (unärer) Operator erwartet.
Klone nach 'openplotter_tmp'...
remote: Counting objects: 3490, done.
remote: Compressing objects: 100% (31/31), done.
remote: Total 3490 (delta 19), reused 30 (delta 12), pack-reused 3447
Empfange Objekte: 100% (3490/3490), 18.77 MiB | 1.82 MiB/s, Fertig.
Löse Unterschiede auf: 100% (2259/2259), Fertig.
Prüfe Konnektivität... Fertig.

CREATING OPENPLOTTER CODE BACKUP...

cp: der Aufruf von stat für \u201eopenplotter/\u201c ist nicht möglich: Datei oder Verzeichnis nicht gefunden
./update_OpenPlotter.sh: Zeile 27: cd: openplotter_bak_2017_08_03:22:48:40: Datei oder Verzeichnis nicht gefunden

APPLYING SETTINGS...

cp: der Aufruf von stat für \u201eopenplotter_bak_2017_08_03:22:48:40/openplotter.conf\u201c ist nicht möglich: Datei oder Verzeichnis nicht gefunden

ERROR UPDATING OLD SIGNAL K SETTINGS

./update_OpenPlotter.sh: Zeile 31: [: =: Einstelliger (unärer) Operator erwartet.

COMPRESSING OPENPLOTTER CODE BACKUP INTO HOME...

tar: openplotter_bak_2017_08_03\:22\:48\:40: Funktion stat fehlgeschlagen: Datei oder Verzeichnis nicht gefunden
tar: Beende mit Fehlerstatus aufgrund vorheriger Fehler

DELETING OLD OPENPLOTTER CODE FILES...


FINISHED, PRESS ENTER TO REBOOT SYSTEM.
Reply
#15
As with the others, upgrade to latest has killed openplotter sadly :Sad
Have deleted the I2C data, but still won't start.



Error message:

No IMU detected
No humidity sensor detected
Traceback (most recent call last):
 File "/home/pi/.config/openplotter/openplotter", line 3503, in <module>
   MainFrame().Show()
 File "/home/pi/.config/openplotter/openplotter", line 268, in __init__
   self.read_compass()
 File "/home/pi/.config/openplotter/openplotter", line 1249, in read_compass
   self.detected.SetLabel(imu_name)
 File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py", line 9207, in SetLabel
   return _core_.Window_SetLabel(*args, **kwargs)
TypeError: String or Unicode type required

Any assistance to rescue my openplotter would be appreciated
(and it was a fresh install)

Thanks, 
Paul
Reply
#16
the same Error here: no Openplotter starting even with "sensors ="
Reply
#17
(2017-08-03, 09:07 PM)JD1 Wrote: Exact same problem (with the I2C section cleared as per your previous post)

pi@openplotter:~ $ openplotter
No IMU detected
No humidity sensor detected
Traceback (most recent call last):
 File "/home/pi/.config/openplotter/openplotter", line 3503, in <module>
   MainFrame().Show()
 File "/home/pi/.config/openplotter/openplotter", line 268, in __init__
   self.read_compass()
 File "/home/pi/.config/openplotter/openplotter", line 1249, in read_compass
   self.detected.SetLabel(imu_name)
 File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py", line 9207, in SetLabel
   return _core_.Window_SetLabel(*args, **kwargs)
TypeError: String or Unicode type required


BTW, upgrades still kill any user generated files (in my case BMV700.py, a driver to take data from the BMV-700 SOC battery monitor and sending the output to signalK)

I have cleared the I2C section in the config file. But the OpenPlotter menu is not working. I had this problem before on the former update.

If there no access to OpenPlotter menu, what is the terminal command to upgrade OpenPlotter if the errors are removed ? Or do I have to fall back on a SD copy ?

Bram
Reply
#18
Ops, sorry guys, I see the problem, easy fix but I need to get to the office to test and upload a new update. That will be around 13h UTC.

A possible and no tested fix: edit the file /home/pi/.config/openplotter/check_rtimulib.py on line 29 change:

result = [[0,0], [0,0], [0,0]]

by

result = [['',''], ['',''], ['','']]

Sorry again, I was excited about new IMU features and I have not tested enough before publishing.
Reply
#19
TESTED..
works for me
thank you sailoog
jim
mare liberum
Reply
#20
Thanks for testing jim!

I have updated the repository and triggered a minor update Angel
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)