This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connection SeatalkNg to CAN-USB stick
We have put the latest version OpenPlotter to the Rasp (0.17.1), that is, I start from scratch, we have a USB stick of GPS and the USB Can Bus to translate the data of the Raymanire NG network.

In managing Openplotter's USB it detects both the GPS and the Can BUS, I configure the GPS (also in the Nemea 0183 tab) in such a way that the OpenCPN positions us correctly.
Let's go with the Can BUS. I do not know why, but if you go directly to the N2K tab, in the USB CAN device tab it lets you select it and Ohhhh surprise, in Raymarine data entry diagnosis appears.

Our problem comes when trying to send GPS data to the network.
First we go to Tools / Generator Nmea2000 where we activate the PNGs:

129025 Position_Rapid
129026 COG_SOG

Now in the N2K tab, in output settings we also select them as well as the input and output of N2K.
In the SignalK tab we restart the server and get the GPS reading to be seen for a few seconds on the Raymarine screen but in a few seconds it will be lost.

Any idea what can happen?
(2018-02-27, 09:59 PM)Alpenskipper Wrote:
(2018-02-27, 06:58 PM)manelvalls Wrote: This week I received the USB CAN...

I tried to connect it directly from the spur cable from Raymarine with the CanH and CanL cables and it didn’t receive data from the net.

Then I’ve used a STng to N2K and it worked at first attempt.

I am intersted in your experience, for I will connect the same adapter to seatalk ng.

Where was the Problem with seatalk ng? For my understanding electrically it is the same bus.

Did you connect CAN H = white and CAN L = blue?
Or do the pins have to be crossed like RX/TX in a NMEA 0183 bus?

[Image: 97b84165b1ac3f3ce39f98009306f700.jpg]

[Image: 74c197a54f22e9747ef0622ea18b3537.jpg]

What was your solution exactly?
skype: trevor_miles

Forum Jump:

Users browsing this thread: 1 Guest(s)