This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenPlotter update to Linux Stretch version
Just tried to upgrade OpenPlotter to the latest Raspberry Raspian Linux version called Stretch.

Although it is not recommended I have done this by changing the server adresses from Jessie to Stretch.

Then apt update and apt dist-upgrade.

See instruction on the website.

Then you get a lot of updated files. It takes some time.

But it all seems to go well and after the update most things worked without problems.

I only had to reinstall zygrib.

And be carefull with the Synaptic server settings. Removed all adresses with Jessie.

At first things did go wrong here because of two version updates have mixed together. Because of the left Jessie settings in Synaptic.

Also OpenCPN was working and it was possible to upgrade OpenCPN to the latest version 2.8.0.

So now I have the OpenPlotter 0.14.4 running on Stretch Linux.
Thanks for testing and reporting. We have plans to create a fresh OP image 1.0.0 from Stretch as soon as beta stage is reached. We will try to keep compatibility with OP 0.10.0 built from Jessie.
The only thing I have to test yet, is the oeSenc plugin and fingerprint. To see if the plugin has survived the upgrade.

I having used Stretch now for some days and can report it works very well and very stable.
Although the screen movement in OpenCPN are not so much faster. The desktop certainly works faster.

Checked the working of the oeSENC plugin and fingerprint. After the server upgrade to the Linux Stretch version the oeSENC chart sets are still working without any problems.

I'am using a 10" touchscreen (Egalax) on board. The touch does no longer work after the upgrade. In the  Jessie version it worked out of the box.

Upgrading OpenPlotter to version 0.15 alpha does not work in the Linux Stretch version.

Desktop is quick and responsive with the Stretch version, but the chart movements in OpenCPN are much slower then the Jessie version.

In Jessie I had OpenGL in OpenCPN set to on. But if I switch OpenGL in OpenCPN to off in the Stretch Linux version the screen movements In OpenCPN are much faster with a lower CPU use !

Why ???
Now using OpenPlotter and Stretch Linux for some time. It works very well and is fast. If I upgrade OpenPlotter in Jessie I then upgrade to Stretch still everything works.

Trying to update OpenPlotter and also OpenCPN in the Stretch version that does not work. Perhaps it has something to do with the signing of the programs. With OpenCPN I get the message
program not signed, it is not safe to install this ..... .

Thanks bram, we have detected a little issue in debian stretch with some opencpn libraries. This problem is also present on oeSENC production. Working on it.

thanks for the message. I have not noticed any further issues. Just got my touchscreen finally working, It is an Egalax (Faytech) touchscreen.

Installing seems easy with the latest driver from EETi but then it does not work.

If you take a look at /usr/share/X11/xorg.conf.d/ there is a config file called
52-egalax-virtual.conf. It you look at the drivers you see "void". If you replace these with "evdev" and restart, then the touchscreen is working.

And you have to install:

sudo apt-get xserver-xorg-input-evdev

The only issue now left, is upgrading and installing, system ask for signing of the software. And add-apt-repository gives an error message.


Done de latest kernel upgrade to 4.9.57. Switched on the VC3 accelerated driver en OpenGL in OpenCPN to on.

Accelerated video with OpenGL now works with a low processor load. Don't switch texture caching to on.

Now the screen movements are fast and Linux Stretch (Debian 9) is very stable. Only the upgrading of OpenPlotter does
not work. And I had to install Egalax touchscreen driver with some adjustments. Do the upgrades in Jessie first before upgrading to Stretch.

All the OpenPlotter items and oeSenc plugin stays working.

Forum Jump:

Users browsing this thread: 1 Guest(s)