This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Updater Quirk
If you watch the Log from the Updater (.16 to .17) you will see an Error:
cant cp aisdecoder because it is locked or busy.

So this binary will never be updated.

Before Updating, the Background AIS Processes should be disabled. (Unckec the ENABLE Button)

Maybe better the Updater should check for any open Processes himself, like it does for Node-Red.

PS: are there Timeouts for the Question "Update Node-Red) y/N"? & for the Reboot at the End?
Anybody using Headless could be waiting forever for the Raspi to get ready. 

Keep on your excellent Work in twentyeighteen.
It has been solved on next version killing aisdecoder before reinstalling.

Yes update node-red has a timeout.

We have added a timeout at the end of update process as you suggested.


Forum Jump:

Users browsing this thread: 1 Guest(s)