This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with USB tethering
Is anyone else having problems with USB tethering? It seems like I'm not getting a DNS server, I can ping an IP address but I can't ping a literal server name.

Sent from my LG-K580 using Tapatalk
I've been researching this problem. Looking at, I see these lines

data += 'allow-hotplug usb0\n'
data += 'iface usb0 inet static\n'
data += 'address\n'
data += 'netmask\n'
The other interfaces, like eth, are set with "iface eth0 inet dhcp".

Is there a reason why the usb interface is declared as static?

Okay, this fixed it for me. In

data += 'allow-hotplug usb0\n'
data += 'iface usb0 inet static\n'
data += 'address\n'
data += 'netmask\n'

data += 'allow-hotplug usb0\n'
data += 'iface usb0 inet dhcp\n'
#data += 'iface usb0 inet static\n'
#data += 'address\n'
#data += 'netmask\n'
data += 'dns-nameservers\n'

Then reboot. You'll have to set your phone to USB tethering in order for the Openplotter AP page to recognize it as a valid internet interface.
(2018-01-07, 11:04 PM)abarrow Wrote: Is there a reason why the usb interface is declared as static?

If you work headless or your monitor is down and your wifi does not work or ...
A workaround could be an android USB tethering phone/tablet.
You can start USB tethering.
Open vnc with fixed IP!!!! and login.
Now you have a kind of monitor to work with openplotter also if other networks don't work.

You're right. The description for this feature is not finished yet.

There is also the chance to use the phone as second wlan to connect to the internet ...
There is also the chance to use the phone as gsm internet connection ...
Not all possibilities are tested (Your addition can be correct for some situations).
Thanks for the explanation - that makes perfect sense. 

I'll try just adding the dns-nameserver line and retaining the static.
I was sitting here at anchor trying to get my USB tethering to work, and finally fixed it. It wasn't a problem with OP at all, it was a problem with the network setting on my Android phone.

What worked for me was to go to the APN settings on the phone, and change them using these instructions found on REDDIT

"Go to Settings -> More -> Cellular networks -> Access point names. Tap the entry for your carrier. Scroll down to APN Type and add ",dun" at the end (so the it should say "default,supl,mms,dun"). Ensure APN Protocol and APN roaming protocol is set to IPV4. Save and try mobile hotspot again."

All working now. All devices connected to the OP access point can get routed via the USB tether connection.

Forum Jump:

Users browsing this thread: 2 Guest(s)