This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
please help me, rasberry pi3 adafruit ultimate gps and openplotter???
#1
Hello everyone, my name is Andrea.
I need your help!
I have a rasberry pi 3 with 7 "touchscreen
then I have a "adafruit ultimate gps"

I installed the "openplotter rpi v 0.8.0" program

I connected the gps to the "gpio 14 gpio 15"

not so what to do to show the gps and GPS data nmea 0183!

I tried various guides but nothing!

please, I need a guide
and on the openplotter settings, to use opencpn!

I'm a beginner, excuse me!
I am convinced that with your help I will solve this problem!
so I will no longer be in pericles with fog at sea!
many thanks in advance!

"explained by google" Italian English! Smile
Reply
#2
Did you connect Rx to tx and Tx to RX.
Serial port enabled
Adafruit has a good How to with pictures
Reply
#3
welcome to the fourm..
http://www.sailoog.com/blog/download-ope...0100-noobs
mare liberum
Reply
#4
According to the adafruit page, it looks like you need a usb to ttl adapter... if you want to do it in a simple way.

https://learn.adafruit.com/adafruit-ulti...spberry-pi

Right. It also seems that you can use the UART pins, but it's more complicated and may end up creating some problems with other OPlotter configurations... I'm not sure.

https://learn.adafruit.com/adafruit-ulti...ead-of-usb

It might have been easier to use a simple gps-USB... even faster and cheaper.
It's not like the sea has such a bad temper.
The real bastard is the wind.
The sea... simply gets carried away.
Reply
#5
Using USB also keeps your serial port available.
Reply
#6
I tested this GPS adapter. I wasn't satisfied. I was hoping the signal would be more accurate.
I tried it with a usb-ttl adapter.
I am now using a GPS USB mouse again.
Angel  Entschuldigung für mein Englisch. Es ist "deepl.com english"
PN bitte auf german.  Big Grin
Reply
#7
thanks to all for the answers, I connected everything right tx to rx and rx to tx!
tomorrow morning work (now I am 1:04 hours) try with the usb ttl adapter, so that you have it, I just have to find it ... hello hello!
thanks again and hopefully, hopefully beyond the memory automatically without having to write lines of code on the terminal!
in case I wait for instructions on what to write!
greetings to all of you from andrea.z
Reply
#8
hello everyone, now it works!
I solved using a "usb-ttl"
cr 2102.
greetings and thanks to all from andrea.z
Reply
#9
What Jim321 is trying to tell you above is before you spend too much time on version 0.8.0, download the 0.10.0 Noobs edition, and you can use the upgrade capabilities within it to bring you up to current code, which is 0.17.0. There is no upgrade path from 0.8.0 directly but after you are on 0.10.0 or higher all or at least most of your settings will carry with each upgrade. Few of us participating here actually run the old 0.8.0 code so we can help you better if you are on the leading edge with the rest of us. Welcome!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)