This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
... make Adafruit Ultimate GPS work?
#1
How to … make Adafruit Ultimate GPS work?

Hi!

I can’t make my Adafruit Ultimate GPS work with Openplotter. The NMEA Inspector freeze almost immediately after it starts when GPS is connected. 
I have been able to make the GPS work on standard Jessie distro, with gpsmon and cgps , but I must have missed something when setting up openplotter.
Any ideas? It is probably something simple…

//Oskar

----
The GPS is connected to a Raspberry Pi 2. I’m using a serial TTL to USB converter. Besides GPS and WiFi USB-stick, no other hardware is connected.

I’m using the latest stable release of openplotter (0.8), and has run apt-get update / apt-get upgrade (a few of days ago), but not installed anything else.

On Openplotter distro I’ve checked I get a steady NMEA-stream from GPS by “cat /dev/ttyUSB0”. Inspector doesn’t freeze if GPS isn’t connected. I just says no data / waiting.
With GPS Inspector has once showed correct UTC time, but usually it only manage to write GP as source or something similar. (I guess it should be GPS, but it generally freeze after 0-2 letters). CPU utilisation is always 100% when running Inspector, with or without GPS.
  Reply
#2
If you got GPS info in inspector window, this means that your settings are right. Be sure you have fixed a satellite position and unplug the wifi dongle or others device to avoid powering issues. Be sure gpsd or another process is not fighting for the same serial connection.
Inspector is very CPU demanding and is normal 100% in Raspberry 2, we will optimize this in v0.9.0. GP is the right source (talker), not GPS.
  Reply
#3
It is advertised as a 10Hz unit, could it be overloading the buffer?
With the MiniGPS tool you can set the update frequency to 1 Hz and try again.
Lowering the speed to 4800 or 9600 is also worth a try
  Reply
#4
(06-01-2016, 04:48 AM)Sailoog Wrote: If you got GPS info in inspector window, this means that your settings are right. Be sure you have fixed a satellite position and unplug the wifi dongle or others device to avoid powering issues. Be sure gpsd or another process is not fighting for the same serial connection.
Inspector is very CPU demanding and is normal 100% in Raspberry 2, we will optimize this in v0.9.0. GP is the right source (talker), not GPS.

Hi!
Thanks for a fast respons, WAY better than price brands like Garmin!!

Replaying in  order of appearance above:

1. GPS info / Inspector window:
Well, I get 1 value before it freeze, as example [Longitude,age: 0.2] or  [Time, source: GP] , and so on, but must restart Inspector between each reading. I get only 1 value before it freeze.  No matter how long I wait. Reset button doesn't respond/give a new value. When closing window, raspberry says "Inspector does not seem to be responding"

2: GPS fix
I can see NMEA output by using cat /dev/ttyUSB0.
Can confirm FIX  by running GPSMON from a standard Jessie distro (not openplotter)

3. Power: 
I have tested with two different power adapters of known brands, rated 5.1V/2.1A and 5.25V/2.5A.
I use a short (40 cm)  cable. I've also tried with a another USB-cable.
And tried without WiFi (but with keyboard, mouse and HDMI instead of WiFi).

4. External Hardware: 
Nothing else is connected than above.

4: Fighting for serial/GPSD:
I'm a newbe. How to check processes fighting for serial connection?
SUDO PS AUX | GREP GPSD doesn't show anything using GPSD, besides grep it self. 
(No other software has been installed. I downloaded latest img to a  SD card and pluged it in, connected to WiFi, apt-get update and upgrade. Thats all. What other process could it be fighting?)

Also checked baud rate with STTY -F /dev/... , it is 9600, which also is what Adafruit says is default. Set up a serial input in openplotter, at 9600. 


//Oskar

(06-01-2016, 01:43 PM)SYWindveer Wrote: It is advertised as a 10Hz unit, could it be overloading the buffer?
With the MiniGPS tool you can set the update frequency to 1 Hz and try again.
Lowering the speed to 4800 or 9600 is also worth a try

Default is 9600 Baud and 1 Hz. I've checked baud rate ant it is 9600, but not update rate.
MiniGPS tool could be worth a try anyway, just to check.
  Reply
#5
Let's try more things...

To check if GPSD is working, open OP, select "set GPSD" from menu settings, check:
star_daemon="false"
USBAUTO="false"

Run Op in debug mode:
Open a terminal and type

Code:
python /home/pi/.config/openplotter/openplotter.py

set the serial connection in NMEA 0183 tab, apply defaults, check opencpn in case signal is arriving, open inspector from OP GUI (not from toolbar). If you get some error in terminal copy and paste here.
  Reply
#6
GPSD setting looks fine

I have reinstalled openplotter on a new SD card, and updated/upgraded to latest release today.

In debug mode I get the following when applying changes after adding serial:

pi@openplotter:~ $ python /home/pi/.config/openplotter/openplotter.py
/home/pi/.config/signalk-server-node/bin/openplotter: line 4:  1741 Segmentation fault      $DIR/signalk-server -s ./settings/openplotter-settings.json $*


I've tried to run Open CPN (on Open Plotter) but it will not start. Is this related to problem above or is something else going on??
OpenCPN works fine when installed on a pure Jessie distro, including getting GPS working and getting 10+ satellites and "green" NMEA messages in "NMEA debug window".

//Oskar
Confused
  Reply
#7
Have you updated with the v0.9.0 branch? Do not do it Smile it is in an early alpha stage.
v0.9.0 will contain the complete signal k implementation and many many improvements, this means major and great changes in all the code. You are getting some error in signal k and it will be really difficult to isolate your problem running v0.9.0, please back to v0.8.0
  Reply
#8
I have only been using att-get and not cloned from GitHub. I thought aptget only uppgrade to stable versions of openplotter, opencpn, and other libraries?

Anyway, 0.8.0 without any update give me the same error as above, except it says "1145 segment fault" instead of "1741 segment fault".
  Reply
#9
ops, sorry.

Let me do some test on a raspberry 2 to confirm your issues.
  Reply
#10
Fresh installation of v0.8.0 running on raspberry 2. All is working right and no errors. The only difference I notice is in preferences>raspberry pi configuration>interfaces>serial. it should be disabled and was enabled. Changed to disabled.

After normal update:
Code:
sudo apt-get update

sudo apt-get upgrade

All is working right, opencpn updates from 4.2.1706 to 4.2.1724 and no errors. No segment errors with signal k server.

You should isolate your problem so I recommend you:
  • Download the compressed v0.8.0 image and pass the checksum test to avoid file corruption.
  • Change your SD to avoid SD corruption.
  • Double check your power source. 80% of issues are power related. Rapsberry 2 makes a worse power management than raspberry 3. Provide enough amp and volts with a reliable power source and cables for the Pi and the future connected devices.
  • Unplug all the connected devices except keyboard and mouse
  • Disable serial interface in raspberry pi configuration menu
  • Check Opencpn from terminal and openplotter in debug mode
  • Do not enable opengl in raspbian nor opencpn, both are in alpha stage.
If you get here without errors we will be able to focus in your adafruit GPS issues.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)