Full Version: tinypilot beta image
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
Sorry I think I made a mistake in that in client mode the menu won't let you switch back to AP if the client can't connect....

The boot is faster than the stable image, but it takes another 30 seconds or so to connect to wifi. I'm not sure how it would take several minutes.

If I look at the log messages from the webdaemon I see the result below.

$ cat /var/log/pypilot_web//current
2020-10-06_18:31:25.49345 processing clients
2020-10-06_18:31:54.86092 Client connected a9c3a1a7d2ec4003a9aed6d31ebbc08a
2020-10-06_18:31:54.86113 failed to read config file: //.pypilot/pypilot_client.conf [Errno 2] No such file or directory: '//.pypilot/pypilot_client.conf'

After I logged in and corrected the time the first message was "No such file".
Perhaps you are looking at a similar problem. What does the TC do after such a message? Wait for a timeout and switch to default settings?

The problem I was looking at was that the pypilot_py client was started without button for +1/-1/+10/-10. After forcing the connection to localhost (and "OK") and later to the client IP (And "OK") I was able to "reset" the TC and make the tiller move. The webpage however was not usable for some time and when looking at the log I found above message.

Perhaps the missing file / faullty path is somehow related?
This message is probably not the issue, it will just use default settings. I'll look into it, I think it's because the web is run as root to access port 80 so it doesn't have $HOME set.

It does take a while for the web services to start up. So wifi is available much sooner, for other connections like the plugin, but yes the web takes a few minutes.
pypilot automatically detects and connects to a signalk server on the network.    So this uses zero conf, and no configuration is needed whether pypilot runs on openplotter, or pypilot is running on a separate computer like tinypilot connected to openplotter by network.

So to utilize signalk you only need to communicate with signalk-node-server which by default is running on openplotter.   This is not really specific to pypilot anymore, but the default port is usually 3000 and it uses websockets or other transports, check the signalk documentation.

I moved this from the multi function display topic, since it seems like it is more appropriate here.

I start my computer before the tinypilot.
When the tinypilot starts there is no automatic connection from the SignalK server in the tinypilot
When I connect to port 3000 either TCP or websocket, I get connection refused
When I connect to port 20220 (NMEA0183) I get the tinypilot paths added to the SignalK data browser

Frankly I don't care about the autoconnect, but as I read above correctly the connection on port 3000 should not be refused.

Tinypilot configured to connect to an existing SSID and a fixed IP-address.
SignalK from the standard setup as mentioned on the github page on both ARM64 and X86_64
Tinypilot SK connected to the ARM64 and via the ARM64 to the X86_64.
OS Ubuntu 20.04 Focal / ARM64 (odroid N2), with github OpenCPN 5.2.x
OS Ubuntu 20.04 Focal / x86_64 (laptop i5) with stable OpenCPN 5.2.0

Also the missing keys on the pypilot plugin:
every start from OpenCPN I have to first select and then the client IP address from the tinypilot. (This might be more appropriate in the pypilot_pi thread though).
Both on ARM64 and laptop.
I mention it here since it might be somehow related.

If I might roundup, I read there is supposed to be some automatic connection feature, which I I don't understand.
Therefore it is hard to trace the problems I face.

I will check tomorroe if the autoconnecting works as intended when the tinypilot provides the host AP.

One last thing:
tc@box:~$ netstat -a
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       
tcp        0      0 (null):20220            (null):*                LISTEN      
tcp        0      0 (null):2947             (null):*                LISTEN      
tcp        0      0 (null):80               (null):*                LISTEN      
tcp        0      0 (null):33333            (null):*                LISTEN      
tcp        0      0 (null):22               (null):*                LISTEN      
tcp        0      0 (null):23322            (null):*                LISTEN      
tcp        0      0 (null):23322            (null):52482            ESTABLISHED
tcp       19      0 box:38404               box:23322               ESTABLISHED
tcp        0    152 (null):22               (null):58756            ESTABLISHED
tcp        0      0 (null):20220            (null):40060            ESTABLISHED
tcp        0      0 box:35268               box:2947                ESTABLISHED
tcp        0      0 box:23322               box:38402               ESTABLISHED
tcp        0      0 box:38402               box:23322               ESTABLISHED
tcp        0      0 box:2947                box:35268               ESTABLISHED
tcp        0      0 box:23322               box:38404               ESTABLISHED
udp        0      0 box:5353                (null):*                            
udp        0      0 (null):5353             (null):*                            
udp        0      0 (null):5353             (null):*                            
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags       Type       State         I-Node Path
unix  2      [ ACC ]     STREAM     LISTENING      13101 /tmp/gpsd.sock
unix  2      [ ACC ]     STREAM     LISTENING      18092 /var/run/lirc/lircd
unix  2      [ ]         DGRAM                     18152 /var/run/wpa_supplicant/wlan0
unix  2      [ ACC ]     SEQPACKET  LISTENING       6644 /run/udev/control
unix  3      [ ]         STREAM     CONNECTED      21048
unix  3      [ ]         STREAM     CONNECTED      20894
unix  3      [ ]         STREAM     CONNECTED      21049 /var/run/lirc/lircd
unix  3      [ ]         DGRAM                      6652
unix  3      [ ]         STREAM     CONNECTED      20895
unix  3      [ ]         DGRAM                      6653

No port 3000...
(2020-10-06, 04:09 AM)seandepagnier Wrote: [ -> ]The wifi changes should be immediate after pressing submit.

I have fixed the wifi issues from the lcd menu today.

so if you can't connect it should be possible to reset by the remote.

I also fixed the route following today.

I have created a new beta image:

Hi Sean

I have tested this new image but I still cannot reset the wifi setting to default via the lcd and remote. If it does not connect to the wifi it only states, no wifi connection and no other options within in that menu.
I know it's broken and I fixed it yesterday.. I haven't made a new image yet. You can reset the wifi manually by editing the file or hopefully I can do this tomorrow.
(2020-10-09, 11:09 PM)seandepagnier Wrote: [ -> ]I know it's broken and I fixed it yesterday..  I haven't made a new image yet.     You can reset the wifi manually by editing the file or hopefully I can do this tomorrow.

I miss understood I though it was presumed fixed. 
Thank you for your efforts
So I tried to use the beta image today. Unfortunately I’m still having issues with the compass wandering and not able to maintain a heading. I’ll have to install a new imu. Will update.

don´t know if this is an issue or if I made a mistake since using.

I used this Image: tinypilot_2020_09_30.img.xz and a Raspberry pi2b

I connected an IMU and get compass heading.
It communicates with opencpn 5.2 and there with plugin 0.22

When using the web gui from an other pc in the Network I can connect to the tinypilot.

All seems to be good.

In the moment there´s no motorcontroller connected.

One point I found out yesterday was the following:

When switching the AP in Compass mode and engaging it the web gui shows the heading and the value "command".

As I understand it is this the course to steer. 
When pressing one of the direction knobs (+ / - 10 or + / - 2) shown in the web gui the command value jumps to 358 (independing from heading) and from there it´s possible to change it in the steps of the direction change knobs (eg -10 or +2 or so).
I didn´t set something in the pid regulator settings. Maybe this is the cause for that.
I didn´t try it from the plugin (forgot to test it). 
I aspected that the command value changed correspondending from witch direction knob was pressed  


The heading is synced to current when you engage normally.
Pages: 1 2 3 4