Full Version: Release the Magic Smoke
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
S***ugar,  The magic smoke poured out of the McArthur board near the LEDs and now the CAN bus is dead.  

The power module was very hot before I quickly powered it down, removed the power module, and restarted with power directly from the Pi. I found that the CAN bus wouldn't connect.  Removing it from the CAN controller and adding it back didn't help.

Running a Pi5 with NVMe SSD headless so not overloaded.

I guess I'll be waiting until summer for another attempt.

Good luck out there and keep your nostrils tuned for that distinctive smell.
It would be very helpful if we could find out what happened.

- Did it work for a while and then the smoke appeared or did it just appear when powering?
- Can you identify which components were burned in a visual inspection?
- Are Raspberry+MacArthur powered by the same battery bank as the CAN bus?
- Was the wiring correct according to the MacArthur HAT version?
- Raspberry model and OpenPlotter version?
Oh no!  Sad   Sorry to hear that. So far, only Sailoog managed to fry a MacArthur HAT. Tongue 

I'm very interested in getting your HAT for a failure analysis. I will send you a private message shortly.

We try hard to prevent users from destroying the HAT (or Pi) through obvious and not so obvious mistakes. So everyone, please don't hold back and share any mishaps, either publicly in this forum, or via private message to Sailoog or myself. It may help us hardening future revisions of the HAT and/or improving the documentation.
Mine was more epic. I connected the router to the MAIANA connection of the MacArthur HAT connected to 12V... fortunately everything survived the experience except the protection diodes of the HAT, you never forget that smell Smile
I think I am the third member of this selected club. I am not sure if I just toasted my MacArthur, but I cannot power it through the Polulu module. 

I've been testing the Hat at home with 5V supply for a few days. Today was the great day and I went to my boat to install everything. I connected the 12V and the 12V led just blinked for less than a second. 

I read the hat documentation and I found something like: "do not power with conventionsl 5V when the power module is installed", which is exactly what I've been doing for two days. Big Grin

Do you think the Hat is completely toasted? Or may it be just the power module? The raspberry works as usual connected to 5V charger. Either way I think I will have to wait until the next batch to fulfill my electronic desires.

Edit: I touched that little piece near the 12V input (B200) and it was super hot. IDK if that's normal.
Try again when this is cold. Think its an autofuse. Good luck. It is Common for the cheap dcdc converters, they do Not like external power on their Output Lines.
Yes, the component marked B200 (and with the F1 designator nearby) is a 2A poly fuse on the 12V input, and it looks like it is tripping.

I don't think that the power module is damaged by leaving it on the HAT while powering the Pi from 5V. We have an ideal diode circuit to prevent current from flowing in the wrong direction. It's still not recommend to power from 12V and 5V at the same time, as that might freak out (or roast) the Pi's 5V regulator.

Try applying 12V and 12V switched to the MacArthur HAT while the power module is removed. The 12V LED should turn on and stay on.

If the LED doesn't stay on, the issue is on the 12V side of the HAT.

Disconnect 12V and use the continuity mode of your multimeter to check for a short on the HAT between the 12V input and GND.

Another possibility is, that your 12V supply is higher than 15V, which triggers the over voltage protection (TVS diode D1), which trips the fuse. Measure the voltage on your 12V supply with a multimeter.

If the 12V side works (the LED stays on), visually check whether there are shorts on the power module. Also double check that you soldered the headers to right side of the power module. It should mount with the tall components pointing downward.

If that looks good, use the continuity mode of your multimeter to check for a short between the 5V and GND pins on the power module itself, the header on the MacArthur HAT, and pins 4 and 6 on the 2x20 RPi GPIO header. If any of those are shorted, you found the problem.

If everything checks out: What else is connected to your Pi in addition to the MacArthur HAT?
Hi Adrian,

Thank you. I tested to power directly 12V without the power module and the 12V led won't turn on. I used the multimeter in continuty mode and I got a few things which I cannot really understand:

- "OL" between 12V and GND solder.
- "0" between B200 sides.
- "OL" and "-OL" between D1 sides.

I didn't do much more research as I frankly don't really know how to find where the problem is. 

I didn't connect anything else into the HAT. I just connected it to the rpi. May it be that I powered it reversed? (I don't remember if I did, but I cannot find any other cause, apart from the 5V charging while power module installed).

Edit: the B200 fuse doesn't get hot now. It seems caput.

Edit 2: I just read another thread in which Sailoog explains the connection of the power switch. I didn't connect the switch. If this is the problem I will love to discover that I'm just another electronic idiot and that the problem may be solved. Let me update you soon, lol.

Edit 3: Problem solved. I think that the problem was that I didn't connect the switch. Lol. Sorry for the inconvenience and thank you so much. Cheers.
any technican around your place would be able to help you.
OK, second person not connecting "12V SW". Obviously, this part of the manual should be rewritten or expanded.
Pages: 1 2