This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Moitessier upgrade problem
Following the Raspberry 4 kernel upgrade and upgrade to latest Moitessier firmware version I get this problem>


insmod: ERROR: could not insert module ./moitessier_5.4.72-v7l+.ko: Invalid module format

ERROR occured!!

Could not load "./moitessier_5.4.72-v7l+.ko".

ERROR occured!!

You might try to install the package again.

dpkg: error processing package moitessier (--configure):
 installed moitessier package post-installation script subprocess returned error exit status 1
Setting up librhash0:armhf (1.3.8-1) ...
Setting up cmake-data (3.13.4-1) ...
Setting up libjsoncpp1:armhf (1.7.4-3) ...
Setting up cmake (3.13.4-1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
pi@openplotter:~ $ 

Any good idea on how to fix this?
It seems that the new kernel has broken the driver again. Rooco guys are working on it, I will notify here when solved.
Yes, it is broken again, even going back to the last stable version did not solve this. the driver installs but the module does not load, so no output.
I tried to activate the internal NMEA Outputs on the moi1-Board to 9600 pi-UART, but no success even here.

Hoping for rocco to fix it soon.

So, DO NOT update to new kernels !!!
The current issue with the package is caused due to a new toolchain used by Raspberry Pi to compile the latest kernel 5.4.72. Unfortunately the community was not noticed about the change. A new package is already in testing stage and will be released very soon.
Thanks for your Work, more that it is not your Fault here.
cool, version works again on raspi 4 anf moitessier 1.

Forum Jump:

Users browsing this thread: 1 Guest(s)