This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspberry Pi 4 released!
#91
Installed again and used this only on a Pi4. Works well., without booting problems. Oesenc usb dongle works. Also SignalK.

SDR receiver here at home seems to work. But adding the correct PPM, the system failed with "wrong PPM". Format outcome PPM is 31.887. What is wrong with PPM ?
Reply
#92
(2019-08-12, 10:09 AM)Sailoog Wrote: We know you are impatient but we are working hard. After some years of OP life and thousands of users feedback we have learned a lot and we think it is time to fix some weaknesses and give the project the professional level it deserves. We have turned the problem of the suddenly release of RPi4 and Raspbian Buster into an opportunity and we have rebuilt OP. This does not mean we start from scratch, we just give a new wrapper to thousands of python lines.

Now OP is easier to maintain and update. As I have promised here are an screenshot and instructions to start playing with it.



Now OpenPlotter is a collection of apps: https://github.com/openplotter

The main app that you have to install first is openplotter-settings: https://github.com/openplotter/openplotter-settings

It is important you install the rest of apps from the openplotter-settings interface, you can see it in the picture above. All apps are converted into debian packages that you can install by "sudo apt install blablabla": https://launchpad.net/~openplotter/+arch...penplotter. On every github repository you can see instructions to help with development, contact us before please.

Instructions to test

Download and install "Raspbian Buster with desktop" image or NOOBS: https://www.raspberrypi.org/downloads/
We do not need the "Raspbian Buster with desktop and recommended software". We recommend the NOOBS way so you will be able to start from scratch easily recovering your system.

Once your Raspbian is running install some dependencies:

Code:
sudo apt install python-configparser python3-wxgtk4.0 python3-ujson whois

An then download and install the latest deb file you will found here: https://github.com/openplotter/openplott...s/releases

Code:
sudo dpkg -i openplotter-settings_2.0.6-beta.deb

And you are done! The first thing to do is to "Add sources" and you will see every app you install from openplotter-settings in the Raspberry menu -> Other
You will see many apps in "coming soon" state but it does not mean that we have to start creating them, we have just to adapt the current code to the new wrapper and make some cosmetic changes.

We have to decide what apps should be done before releasing the first OpenPlotter 2 beta. When the rest of apps are done or there are new ones, they will appear magically in the openplotter-settings menu.
 
Please do not use this test in production systems, I mean do not sail with this yet! Do not start translating yet, wait for the source files to be in crowdin.

Enjoy!
Installation according to your instructions for Ok test but "OpenPlotter Sttings" and "OpenCpn install" does not work : unable to access the "Install" and "Uninstall" commands ... see screenshot. I'm not very good with Raspian! Thank you Best regards


Attached Files Image(s)
   
Reply
#93
(2019-08-13, 10:54 AM)verkerkbr Wrote: Installed again and used this only on a Pi4. Works well., without booting problems. Oesenc usb dongle works. Also SignalK.

SDR receiver here at home seems to work. But adding the correct PPM, the system failed with "wrong PPM". Format outcome PPM is 31.887. What is wrong with PPM ?

Your PPM is 31,887 -> use 32 or 31 PPM.
Reply
#94
Changed the PPM to 31 and now it seems to work. DSR is starting. Although I don't see any ships pass by OpenCpn.
But perhaps there are no ships at the moment. Look at this tomorrow. Thanks for the advice.

Bram
Reply
#95
Two remarks.

SDR is starting. (PPM added manualy in the config). But no ships passing by here on the OpenCPN screen.

Cannot change the name and password in the AP screen. Not saved.

Otherwise working very well both on my Py 3B+ and P4.


Attached Files Image(s)
   
Reply
#96
(2019-08-13, 07:12 PM)Papyrus Wrote: Installation according to your instructions for Ok test but "OpenPlotter Sttings" and "OpenCpn install" does not work : unable to access the "Install" and "Uninstall" commands ... see screenshot. I'm not very good with Raspian! Thank you Best regards

Yes, sorry. That happens if you have your system in a different language than English. This afternoon I will publish new versions of all apps with many errors corrected. An the I2C app working.
Reply
#97
(2019-08-14, 01:52 PM)Sailoog Wrote:
(2019-08-13, 07:12 PM)Papyrus Wrote: Installation according to your instructions for Ok test but "OpenPlotter Sttings" and "OpenCpn install" does not work : unable to access the "Install" and "Uninstall" commands ... see screenshot. I'm not very good with Raspian! Thank you Best regards

Yes, sorry. That happens if you have your system in a different language than English. This afternoon I will publish new versions of all apps with many errors corrected. An the I2C app working.

Thanks!
Reply
#98
(2019-08-14, 10:42 AM)verkerkbr Wrote: Two remarks.

SDR is starting. (PPM added manualy in the config). But no ships passing by here on the OpenCPN screen.

Cannot change the name and password in the AP screen. Not saved.

Otherwise working very well both on my Py 3B+ and P4.

Yeah, that AP error is what I expected in my compilation.

I'm testing the new installation method through the openplotter-settings app and in this case the AP already works well and can be configured. Only there are still some things to implement in the App. Be patient.
Why are sailors more daring than other men?
Because: No man is so often afraid
like the sailors.

"Of the questions of the seafaring world", in
The Tree of Science, Ramon Llull
Reply
#99
NEW update of OpenPlotter 2 beta available. If you have already installed the "OpenPlotter Settings" app you can update through the app itself, for new installations follow this: http://forum.openmarine.net/showthread.p...79#pid9879

It contains fixed errors and the app openplotter I2C is fully working. Xygrib is added too.

Next week we will be sailing so no updates Smile
Reply
getting errors
terminal

==== AUTHENTICATING FOR org.freedesktop.policykit.exec ===
Authentication is needed to run `/usr/bin/python3' as the super user
Authenticating as: ,,, (pi)
Password:
==== AUTHENTICATION FAILED ===

openplotter-settings

polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
Error executing command as another user: Not authorized

This incident has been reported.


------------------


installed tightvnc on opz it works from desktop as expected. i guess it didn't like running on ssh -X
mare liberum
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)