This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Raspbian bug kills Moitessier HAT systems after upgrading to kernel 4.19.118
According to rooco guys:

"There is no need that they upgrade the kernel manually, this is done by the script I provide. If the update is done manually, booting will fail as the manual update will overwrite the dtbo file again. The description on our web page mentions that the script will automatically update the system. Manual updates are not possible as long as the kernel is not fixed. For any future update use the script."
I've got it going!
It runs with the 2.01 version.
And the Pi boots from USB SSD !!! Smile (without own power supply)
I still have a few problems.
I think I need more power on the USB ports.
The Pi currently only boots on the USB2 ports.
As soon as I connect something to a USB3 port works
unfortunately not anymore.
Even the USB SSD alone on a USB3 port no longer boots Sad

I will test an active HUB ...
I would be grateful for ideas and tips Smile

I still have not been able to get the bug-fix installed. I'd appreciate better instructions on getting it done.
(2020-07-01, 07:59 PM)jamieFL Wrote: I still have not been able to get the bug-fix installed. I'd appreciate better instructions on getting it done.

After installing Moitssier package and running bugfix script and before reboot copy dtbo manually:
sudo cp moitessier/dtbo/i2c-gpio_bug_fix_4.19.118.dtbo /boot/overlays/i2c-gpio.dtbo
I have tried option 1 a number of times- always receive error when installing package as well as update script- it seems my I2C is disables and can no longer be enabled.
So I exported my tracks and went for a clean install.
Should have known not to update a working system Sad
Maybe a warning on the image download page ( is also in order- one of the first things the Pi setup script does is get all updates... After that it won't boot. The fix doesn't work on these installs either.

Or better yet-update the Moitessier images so they have the fix pre-loaded..?..
A new image would be the best option but we are busy these days, we will do ASAP.
Rooco is double checking the manual to improve it.
There is a new package available and a new description.
This should solve the issue reported on some systems. Keep in mind, that if you do a manual apt-get update, upgrade and/or dist-upgrade the system will not boot anymore. Use only the bug-fix script to update/upgrade your system.
@sailoog , @Roocco

Will there be support for SSD boot in the near future?
(2020-07-10, 10:46 PM)rastam4n Wrote: @sailoog , @Roocco

Will there be support for SSD boot in the near future?

That would  be a question for Raspberry OS developers. As a general rule, if it works for Raspberry OS it will work for OpenPlotter.

Forum Jump:

Users browsing this thread: 1 Guest(s)