This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Openplotter 2 (latest) NMEA out Woes
#21
Sorry, my mistake, forgot that you had nmea0183-to-nmea0183 included.

So, your setup is correct and should be working - now we need to figure out why it isn't.

It would be helpful if you could share your settings, located at /home/pi/.signalk/settings.json and /home/pi/.signalk/plugin-config-data/nmea0183-to-nmea0183.json. Earlier I asked about invisible characters like spaces in the event names - these would not show in the screen captures, but would show up in the settings files.

Do you really need nmea0183-to-nmea0183? You could try the value OPENCPNOUT in APREPEAT connection's Output events field. This would forward all data from OPENCPNOUT to APREPEAT.

(2020-07-06, 10:35 PM)sparticle Wrote: My connection OPENCPNOUT is not emitting anything as far as I am aware.

The events are internal to the server, so you would not be aware of them being emitted - same thing as you are referring to with "datastream" and "outputting events".


(2020-07-06, 10:35 PM)sparticle Wrote: My naming convention works for me and is perfectly logical. 

I understand it works for you, I was trying to point out that the naming is a bit ambiguous and may not be clear to others.
Reply
#22
(2020-07-08, 08:54 PM)tkurki Wrote: Sorry, my mistake, forgot that you had nmea0183-to-nmea0183 included.

So, your setup is correct and should be working - now we need to figure out why it isn't.

It would be helpful if you could share your settings, located at /home/pi/.signalk/settings.json and /home/pi/.signalk/plugin-config-data/nmea0183-to-nmea0183.json. Earlier I asked about invisible characters like spaces in the event names - these would not show in the screen captures, but would show up in the settings files.

Do you really need nmea0183-to-nmea0183? You could try the value OPENCPNOUT in APREPEAT connection's Output events field. This would forward all data from OPENCPNOUT to APREPEAT.

(2020-07-06, 10:35 PM)sparticle Wrote: My connection OPENCPNOUT is not emitting anything as far as I am aware.

The events are internal to the server, so you would not be aware of them being emitted - same thing as you are referring to with "datastream" and "outputting events".


(2020-07-06, 10:35 PM)sparticle Wrote: My naming convention works for me and is perfectly logical. 

I understand it works for you, I was trying to point out that the naming is a bit ambiguous and may not be clear to others.

Thank you I will be going to the boat in the next few days and will forward those files. I will try and can the nmea0183 to nmea0183 app. and try and direct OPENCONOUT in APREPEAT. I believe I did try this. But will go around this again.

Thank you for your support.

Cheers
Spart
Reply
#23
Hi, Just to clarify, I am also struggling with exactly this problem and there didn't seem to be an accepted solution, yet this must be one of the most common setups. I must admit, it was easy in Kplex, but I can't get that to work either now either in V2.0.

I have a laptop running OpenCPN, RPI3+ with Openplotter, ST60 Instrument and Autopilot (NMEA0183), and a Garmin 128 GPS
Is there a simple write up of the settings for such a configuration. I would help if there was an easy way to see the datastream into Signal K like the OpenCPN debug which shows the data and the source.
Thanks
Richard
Reply
#24
Hi, where has this got too, I have a similar basic setup that I can't get working, yet it was fine on the old version 1. I have a Win 10 laptop running OpenCPN, and a RPI3+ with openplotter v2, with Signal K 1.33.
I want to send Autopiliot data from Opencpn to ST6000 autopilot on NMEA 0183. I have an serial input from ST60 instuments in NMEA0183 to Signal K and Openpncpn receives this via TCP.
I can output from OpenCPN on UDP and can see this data in Signal K, but it's not being transmitted to the Autopilot.
I also tried a direct link as suggested here from OpenCPN using serial on port /dev/ttyOP_nmeaout. I can see the data in the debug screen in blue, but nothing on the Autopilot.
This would seem a very basic setup which I have patiently working at - it shouldn't be this difficult when Kplex just worked.
Anyone got a simple write up, before I revert to version 1 again?
Thanks
Richard - floating around in Greece.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)