This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 2 Vote(s) - 4.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New Py Zero 2 W is Out!
#51
Hello Stelian
i tried your image and it seems to work as shipped.

Because i have a strange jlx12864 display, i need to change the commands in the ugfx.cpp file and build again with pypilot.build.

When i do this, the web controll interface doesn't work. I looked at ~/pypilot/web folder and the file web.py seems corrupted to me.
Reply
#52
Hi kagouraki,

I don't see any web.py corruption here...

I too have some strange issues when building using pypilot.build:

First of all you need to wait a few minutes after the boot so all the needed development packages (gcc etc) get installed.

Then, from the pypilot directory, run "sudo python3 dependencies.py", some extra python packages will be installed through pip, I think some of them may be required for the build.

Then run "sudo sh pypilot.build", which will build and install the tcz package.

However, for some strange reason I haven't investigated yet, it seems that you need to build TWO times: the first package which is built is not ok (if you look closely, at the end of the build, where the size of the package is shown, you will notice the new build is a few kilobytes smaller than the previous). This is the sign that the build is incorrect. Issuing the pypilot.build a second time will build a correct package.

I really need to look closer into this !
Reply
#53
Yes. i looked it again. The web.py file is corrupted look at the picture. They have different sizes.
Also as long as i checked, the filesize of the package is the same when i run the pypilot.build for a second or a third time. It doesnt change when i build again.


Attached Files Image(s)
   
Reply
#54
Latest web.py (https://raw.githubusercontent.com/pypilo...web/web.py) is exactly 6.8 kB in size, so it looks like the file on the sdcard (rightside picture above) is OK.
Reply
#55
Hi Stelian,

I went back to my ship after a huge storm (gusts with 11 Bft) yesterday evening, so I finally got my dmesg log. Sorry for the delay!!!

Kind regards,
Hans


.txt   dmesg.log.txt (Size: 20.6 KB / Downloads: 50)
Reply
#56
Hi hans-martijn,

Thanks for the dmesg log. Is this with the faulty USB cable attached ?

Because I see some USB related errors in the logs:

Code:
[    4.375481] usb 1-1: device descriptor read/64, error -71
[    4.495543] Indeed it is in host mode hprt0 = 00021501
[    4.705452] usb 1-1: new full-speed USB device number 3 using dwc_otg
[    4.705847] Indeed it is in host mode hprt0 = 00021501
[    4.935450] usb 1-1: device descriptor read/64, error -71
Reply
#57
It also seems a kernel module crashed?
Reply
#58
Yes, it is caused by a missing kernel module in initrd (sha256_generic.ko). I tried reporting this to tinycore but their forum is down again Sad

Anyway, the crash doesn't effect the wifi functionalty, and it can be worked around by extracting the missing module from http://tinycorelinux.net/13.x/armv7/rele...les.tar.xz and insmod'ing it before loading wireless.tcz
Reply
#59
(2022-01-09, 02:29 AM)kagouraki Wrote: Hello Stelian
i tried your image and it seems to work as shipped.

Because i have a strange jlx12864 display, i need to change the commands in the ugfx.cpp file and build again with pypilot.build.

When i do this, the web controll interface doesn't work. I looked at ~/pypilot/web folder and the file web.py seems corrupted to me.

Out of curiosity, how is your jlx12864 strange that it requires a rebuild?   I could incorporate your changes somehow, at least to make it easier for you in the future maybe?
Reply
#60
Sean, 
My raspberry pi zero 2 that I thought was burned is not.
I managed to install the beta image and everything works GPS, jlx12864 screen, windsensor Yachta by lan, but not able to detect imu. I have tried 2 imu9250, and 2 ICM 20948, none of them are detected.

Which imu are you using?
Pierre 
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)