This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Wired ethernet link between Tinypilot and Openplotter Raspberry
does restarting pypilot restore the signalk connection or only restarting signalk?
This seems like the same problem reported by hans-martin on the other thread ( and which is supposedly fixed in newer pypilot code.

So I think that if you try Sean's latest beta or my image from yesterday this will work fine.

However, it seems that there might be issues between the OpenCPN pypilot plugin and the latest pypilot, although it's not clear to me if those issues are with the latest 'master' pypilot or Sean's 'beta' or both...
Hello Sean and Stelian.
@Sean, when I loose the connection, the SignalK dashboard show no activity for ws.pypilot. When logging in then restarting SignalK without any other action, the connection is restored.
@Stelian, I will try the beta image and your last image and I will report the result.
Thank you for your help. Eric
Hi all, so I am trying the latest Sean's version that is working fine, but I am afraid that the SignalK issue is still there. I have loosed again the SignalK connection, maybe after longer time. I will make some other trial with the wired Ethernet link and without it to know if the issue is linked to this wired connection or not.
Otherwise,I have noticed that the version number is 0.40 in the software, but the display during initialization is 0.33.
Hello, I have probably solve the issue. I am running the OP Raspi at home with a GPS mouse and on board with a integrated GPS antenna. As I had kept both links in the OpenPlotter serial tab, leading to a conflict in SignalK. I have now removed the unused USB port and connections and I restarted my trials that seems ok until now. Sorry to waste your time on my mistake. Eric
Hi Sean, your latest beta version seems to work fine (on desk for now) but I am disappointed of the loose of mode choice in the remote control setup. I have found this choice very useful on the RC remote control. Did you think possible to make this choice available again? Many thanks, Eric
Hi Sean, I am sorry to push up my question regarding the RC remote control, but maybe have missed it.
Did you think possible to put back the possibility to choose between modes (compass, GPS, wind) on with the RC control in your next release. I have no idea of the difficulty to get it.
Thanks, Eric
So the signalk problem is solved?

The modes got broken since they were enumerated. It should be fixed now:
Hi Sean, I am currently running my equipment at home with your last beta release and that working fine since some hours without lost of SignalK. Previously I have made trials with the 0.32 version but with some lost of signalK, so I think that it's OK now. Meanwhile I havealso changed eth0 IP adress to as I noticed that this address appearing given by the system before to be changed by my ifconfig command for Please don't laugh if my supposition seems totally false!
Hi Sean, sorry to not reply faster on this thread, I was doing some trials with the Stelian's release.
I try now your beta release 0.40 issued from a link given by Stelian and I will have more questions and observations for you.

Firstly, I would like to try your last modifications but I don't now how to compile the files, it's over passing my level of knowledge ! So I will wait your next release or maybe can you give me some instructions to make the pypilot.tcz file.

This 0.40 release seems work fine with no issue from the SignalK connection until now but as said to Stelian I have uninstalled pypilot on my Raspi running OpenPlotter that was maybe issuing conflict. By the way, I would like to know if it's possible to run pypilot services remotely from OP without installing fully Pypilot, mainly for pypilot_scope.

I have noticed on web control the mode choice is not working, but that maybe solved by your last modifications.
On the ergonomic aspect I noticed that Heading and Command are inverted in comparison with OpenCPN Pypilot addon, maybe confusing.

Thanks to spend time for basic users.

Forum Jump:

Users browsing this thread: 1 Guest(s)