This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenPlotter 4 roadmap
(2024-03-14, 11:42 PM)Opie91 Wrote:
(2024-03-14, 01:19 PM)PaddyB Wrote:
(2024-03-14, 11:31 AM)holgerw Wrote: On my boat, since using an cheap wifi-Router with LTE, all the Quirks are gone.
Try this First. The pi os is Not really an Multitasking and realtime Software.

So do yourself an favor and Remove The Software hotspot.

Holger

Possible is this: the opencpn with Peer to Peer leaves not enough cycles for the hotspot.

Remove one Point of error after the other, and i would start here.

I've been using a Pi for many years & the local created network has never been a problem, even running openplotter on a Pi Zero for several years. Send to peer  was completely fine on OP3 on a Pi3. This is almost certainly settings somewhere hidden....

Hi PaddyB,

I had all kinds of connection problems with the hotspot created by the pi. In the end had to reimage it and set up the network first thing, after that no issues. I saw several other posts that mentioned something similar to this.

It seems that the native hotspot is not as good as the one in OP3.

Thnx though it seems rock solid, it's just that opencpn running on the Pi won't send to peer.
Reply
(2024-03-15, 01:45 AM)PaddyB Wrote: Thnx though it seems rock solid, it's just that opencpn running on the Pi won't send to peer.

Not sure if this should be in bugs or not but for now... http response -1 is about communication errors between machines, I'll keep digging for now, just to recap >> with opencpn running on  a laptop, android tablet 6 openplotter V4 on a Pi4 the laptop & tablet will seed to peer to each other but not the Pi. 

https://www.cruisersforum.com/forums/f13...ost3881110
Reply
(2024-03-11, 06:26 PM)Sailoog Wrote:
(2024-03-08, 08:27 PM)aitonos Wrote: HI!

I just bought a Pi5 8GB, installed it the OP4 Beta Starting and I could manage to have GPS from USB Gps. All fine
Now I have tried to use the Moitessier hat2, which I have running every day in my PI4 but  it doesn't work connected to PI5: it doesn't light the lights and in Signal K says there's no incoming activity.

Just as a reminder; I do all the steps in the docs for hacking the moitessier hat:
  • In serial settings,  I activate the UART0, get the message that I  will lose BT connection ( BUt I still have it, maybe this is aclue) I restart  PI and then, I get 2 connected devices: TTYAMA0 and TTYAMA10. (but nothing else is connected at the time) (??)
  • In the serial devices tab, I create an alias  for  TTYAMA0, as  nmea0183 data, 
  • Then apply, 
  • then in Connections tab, I make a connection of that device to Signal K with the right bauds 921600,  
  • Signal K restarts and in the SK dashboard I can see that the connection has been created, wih no activity and  and connection and plugin status  is green and connected
  • All correct as per instructions, I already did it for OP3 in my PI4!

The problem is that in the PI5, there is no activity at all and no lights in the pcb of the hat ( in PI4 the lights are on as soon as the PI starts). I installed it back to the PI4 and it is working as usual, si the HAT is fine.

What am I missing?

Has anybody used the Moitessier HAt in the PI5? Or should I leave it for impossible for now until OP4 is released?

Thanks!!!


You should not get the message about Bluetooth if the Raspberry is detected as model 5.

what power supply are you using in your RPi5?

are you indoor when testing RPi5? try to go to the boat, outdoor or close to a window.

Hi! 

Thanks, but I do get it. I'll make a new fresh install to see. 
I'm using a step-down bucket with 6A capacity and wired to a USB terminal with screws (the bucket has no usb exit just wires positive and negative out).
I'm at the boat, and did it outdoors, the problem is that the lights don't shine as in Pi4. When the Pi4 gets no signal, you always get light during boot and standby.
Anyway, I'll wait until Pypilot is stable and can be calibrated (IMU). 

¡Thanks!
Reply
I have been an IT-consultant for NGOs and Pulp/Waiste for 30 years (>= 100 employees) delivering mission-critical stuff.

I have been a boat-owner for 9 months.

I just want to emphatically emphasise that the Openplotter, SignalK and SensESP (and surely many more projects) are BRILLIANT!!!

Your work is stellar and HUGELY appreciated.

I am only 40% into my tinkering-journey but a goal for me is to one day be able to contribute professionally and essentially.

THANK YOU!!!
Reply
I have added openplotter-gpio v4.x.x but only 1W is enabled.

Many other applications have been updated and it is important to update them all or some errors may occur.

There is a great change and improvement. Now all connections from OpenPlotter applications to the Signal k server are managed by OpenPlotter, so they no longer need to be configured by the user.

This change is important because these connections were the reason why these apps could not be pre-installed in the official OpenPlotter images since all OpenPlotter installations would share credentials, causing a great security weakness. OpenPlotter will now create unique credentials for each installation even though they were installed from the same image.
Reply
GPIO 1W working perfectly. Thanks!
Reply
I've got a new RPi 5 with a fresh install of the Open Plotter 4 touchscreen image. I've tried installing the Flatpak version of OpenCPN to have the touchscreen zoom functionality but OpenCPN is crashing immediately if selecting option to Add Directory on the Chart Files page or Add Dataset on the Tides & Currents page. The same flatpak install on OP3 seems to work ok.

Is anyone else seeing the same issue?
Reply
I had a similar problem. Try enabling OpenGL

Settings>Display. Once enabled click the options link and select "Software OpenGL (restart OpenCPN)".

Close and reopen OpenCPN.
Reply
(2024-03-22, 12:38 AM)Opie91 Wrote: I had a similar problem. Try enabling OpenGL

Settings>Display. Once enabled click the options link and select "Software OpenGL (restart OpenCPN)".

Close and reopen OpenCPN.

That didn't work.  OpenGL was already enabled and after I selected the Software OpenGL setting and restarted, the checkbox for enabling OpenGL is greyed out and not selected.  It seems like there's something else at play here.  

Also, selecting that option also now causes OpenCPN to crash on startup every other time it starts. The times it doesn't crash is when it pops up the warning dialog to say it crashed last time.

All I'm really after is for two finger zoom to work on the touch screen.  Is there a reason it won't work with the deb package versions and can that be fixed, or is it a non starter?
Reply
My waveshare touchscreen stop working after a system update (kernel 6.6.20) and when I connect headless I can not even start OpenCPN flatpak, it crashes immediately if the monitor is still connected. If I disconnect the touchscreen and connect headless, OpenCPN flatpak works OK.

I will try to get a Raspberry official touchscreen.

What is your touchscreen model?

Could you try disconnecting the monitor and connecting by remote desktop?
Reply


Forum Jump:


Users browsing this thread: Sully, 2 Guest(s)