This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenPlotter 4 roadmap
Let me take a look at mairas's solution.

@mairas, do you have details on the performance of the dual connection?
Reply
Hey, not sure if this is an OpenPlotter 4 or Bookworm issue, but my mouse is extremely slow (laggy) when running the desktop.  Anyone have a fix?
Reply
(2024-03-30, 10:32 AM)tsr Wrote: Regarding the withdrawn OpenPlotter Network app:

That made it super easy to connect as a WiFi client (marina or phone) and provide a local hotspot simultaneously. I cannot figure out how to do the same with just the built-in facilities. All instructions I see online require extra scripts or even compile code. My worry is that those methods integrate less smoothly with the system than the OP network app did. (I hope my admiration is obvious now.)

Any instructions I didn't see or other recommendations?

hello tsr
I had this same problem which I solved by adding a rule in /etc/udev/rules.d/90-wireless.rules containing
ACTION=="add", SUBSYSTEM=="ieee80211", KERNEL=="phy0", \
    RUN+="/sbin/iw phy %k interface add wlan9 type __ap"
this creates a wlan9 virtual interface (same operation as under OP3)
Reply
(2024-03-30, 12:27 PM)Reaction Wrote: Hey, not sure if this is an OpenPlotter 4 or Bookworm issue, but my mouse is extremely slow (laggy) when running the desktop.  Anyone have a fix?

I had this problem when running OpenPlotter 3 on a Raspi 4.   I found it much more responsive not to use vnc, but rather connect to openplotter.local:3000 from my MacBook and to open direct gui applications from "ssh -X ..."   For example, any of the "openplotter-*" utilities.

I am now running OpenPlotter 4 on a Raspi 5 and vnc is much more responsive but I am using X11 and not the default Weyland.  Open a terminal and run the command "echo $XDG_SESSION_TYPE".   If you're not running X11 then give it a try.
Reply
I am doing some testing with the virtual interface and it works quite well. I think I will implement this in openplotter-settings to enable/disable a dual Hotspot/client system with one click.
Reply
(2024-03-30, 12:07 PM)Sailoog Wrote: Let me take a look at mairas's solution.

@mairas, do you have details on the performance of the dual connection?

I've been running it on some CM4 devices for a week or two and it's been reliable and solid. No issues whatsoever. Didn't test the actual throughput but it should be identical to the Bullseye hostapd approach. Also, I haven't looked whether it's possible to configure DHCP, local DNS or other settings. It might be that hostapd is more flexible in that regard. But it's very handy to be able to manage the connection directly from NetworkManager.
Reply
OK, done. In openplotter-settings v4.1.2 you will find a new button "Hotspot+Client" in "Raspberry Settings".

   

OpenPlotter will add the necessary files and will configure everything. To enable and disable the Hotspot+Client feature just click that button and then edit the password in network manager to be safe. The new password will remain even if you disable Hotspot+Client later.

Another way of disabling/enabling Hotspot+Client is typing this in a terminal and rebooting:

openplotter-ap enable
openplotter-ap disable

That is what we will use in openplotter-gen.

Tested in RPi 4 & 5, wayland and X11.

Test and report as usual. Thanks.
Reply
(2024-03-30, 08:16 PM)Sailoog Wrote: ...

Test and report as usual. Thanks.

Thank you. There is one remaining issue: I can't set up NetworkManager to disable WPA for the AP so clients (rightfully) complain about the insecure connection. Not a problem while under way Smile, but when in a marina people might be tempted to try their luck, for example https://github.com/david-palma/wifi-cracking
Hostapd (openplotter-settings) still had an important advantage.
Reply
I’ll try this also. Everything GPIO and 1wire is working for me - many thanks!
Reply
Added digital inputs/outputs to openplotter-gpio v4.

Tested on RPI 4 & 5. It uses gpiod instead of pigpio or RPi.GPIO or GPIO Zero.
Reply


Forum Jump:


Users browsing this thread: CarinaPDX, 2 Guest(s)