This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Enable mdns
#1
I was having trouble with 'Autopilot enabled" and Pypilot was stealing data from SK which meant I had no heading or attitude data for OpenCPN or KIP etc.

When I switched to "IMU Only" SK was getting data.

In Serial App "Add to Signal K" & "Add to Pypilot" are greyed out. 

I had a look at the Pypilot Workbook > Signal K Connections & turned on mdns in the Server Settings & I was connected to SK!!!! Smile

Maybe this needs to be included in the Docs.
Pi5 8GB, NVME SSD 512GB, MacArthur hat, OP4,
Reply
#2
I dont understand what you mean "pypilot stealing data from SK"

pypilot discovers signalk via mdns, maybe that is what is happening?? This should be automatic so I am not really sure I understand. I didnt know it could be disabled.

pypilot also uses mdns to discover itself, like from different instances or hosts.
Reply
#3
(2024-05-13, 07:48 PM)seandepagnier Wrote: I dont understand what you mean "pypilot stealing data from SK"

In the Server Settings mdns was not turned on & when I was in "Autopilot Enabled" there was no data from Pypilot going to SK.

Since I turned on "mdns" all is good.
Pi5 8GB, NVME SSD 512GB, MacArthur hat, OP4,
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)