Full Version: OpenPlotter 4 (based on Debian Bookworm)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
As you can read in the docs, we always need a new major version of OpenPlotter when Debian officially releases a new major release and Raspberry OS releases a new major release based on this Debian release. So, we are already there, Raspberry 5 will need a new version of Raspberry OS based on Debian Bookworm and we will release OpenPlotter 4 based on Raspberry OS Bookworm. This time OpenPlotter 4 will work only for 64 bits.

OpenPlotter 3 needed a lot of changes because some applications were not even in stable state and some breaking changes were waiting for a major release to be applied. This time OpenPlotter 4 will just need some changes to adapt all the apps to the new OS, not big or breaking changes are waiting. It should be a smooth transition and we will start it when the dust of Raspberry 5 and Raspberry OS Bookworm has settled.

This thread should serve to announce some important changes and collect your proposals. If we have been able to maintain this project for so many years it is because the most important premise has always been "make it simple." Think about this before proposing new features.

EDIT: Please follow the development of OpenPlotter 4 here:
After testing the official Raspberry OS Bookworm, the first big improvement we can see is that they have added "Network Manager" to handle network connections. This means that now you can set access points using this tool.

The openplotter-network application is probably not worth keeping because creating a hotspot was the main goal of this application and this always involves invasive configurations on the host system. We could move the extra tools of openplotter-network to a tab "Network" in openplotter-settings.
Has anyone been able to get VNC working on Raspberry OS Bookworm?

I always get: "Unable to connect to VNC Server using your chosen security setting. Either upgrade VNC Server to a more recent version from RealVNC, or select a weaker level of encryption."
(2023-10-13, 11:58 AM)Sailoog Wrote: [ -> ]Has anyone been able to get VNC working on Raspberry OS Bookworm?

I always get: "Unable to connect to VNC Server using your chosen security setting. Either upgrade VNC Server to a more recent version from RealVNC, or select a weaker level of encryption."

Yes I have it working although like you I struggled for ages to make it so. I got the same message as you. If I connected a mouse/keyboard I could see that the normal RealVNC icon was missing from the top taskbar.

This is what I did:

Downloaded the 64 bit Bookworm image for the pi
Using Raspberry imager I created an SD card, enabling SSH, Wifi credentials etc
Put the card in and booted
SSH in
did a sudo raspi-config
Display Options>VNC resolution I set to 1920x1080
In advanced options>A6 Wayland I selected X11, ok, Finish
A reboot was called for so I did that

On reboot I SSH in, went into raspi-config again and in the Interfaces section I enabled VNC

After that I could VNC in without a problem and the RealVNC icon was on the top taskbar as expected.

I could probably have enabled VNC the first time in raspi-config but I didn't try that. I suspect the key is the Wayland/X11 option.
After further investigation I realized that in Raspberry OS bookworm, Wayland is used instead of X11. RealVNC does not work in Wayland so they have switched to WayVNC VNC server. X11/RealVNC still works in Raspberry 3 and older but Wayland/WayVNC will be the remote desktop environment for Raspberry 4 and 5.

I think OpenPlotter 4 should also use Wayland/WayVNC. I have been able to connect from Remmina in Ubuntu using this config in Raspberry OS bookworm:



This will allow a non secure connection. Investigating how enable SSL in Remmina.
With Bookworm, Pi 4 and 5 now use Wayland (and WayVNC server) by default. Pi 3 and earlier still use X11 (and RealVNC server).

RealVNC client won't connect to WayVNC server, so the RPi developers are recommending TigerVNC client instead.

If you really want to keep using RealVNC client, you can reconfigure your Pi to use X11 (as baltika_no_9 has done). But this only works with x64 right now, x32 is broken due to a separate RealVNC bug.

See here for details:
Confirmed, TigerVNC works OK in Ubuntu even with SSL and authentication enabled:


More Wayland issues.

I have not been able to run any on screen keyboard. It seems that there are some on screen keyboards recommended for Wayland but not luck yet: maliit-keyboard, squeekboard.

Any idea?
have you tried onboard?
(2023-10-14, 05:34 PM)Norm Wrote: [ -> ]have you tried onboard?

Yes, i does not work in Wayland.
Pages: 1 2 3