Full Version: New Py Zero 2 W is Out!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
@Stelian: I only tried your image I tried both, but nothing happened on my signalk-server unfortunately. I wouldn't mind putting settings in a menu or create an account for the pypilot in the signalk-server, because now I cannot see what goes wrong...

Hmm, in a previous post Erickalon said that signalk was working fine for him.

I wonder if the issues could be caused by something at startup (boot delays ?).

Please try the following:
- start your signalk server, and tinypilot
- wait a few minutes for boot to end
- at this point, as you reported, signalk is not working, right ?
- log in to the tinypilot over SSH
- in the SSH console, type 'sudo sv stop pypilot ; pypilot'
- tell us if it works now, and if it does not paste the startup logs


(2023-04-02, 12:18 PM)Erickalon Wrote: [ -> ]Hi Stellian, I would like to test your new pypilot.tcz but I don't know the installation process. My progression in Tinycore use is very slow... Can you please explain me how do?
The running configuration works rather well, but the SignalK connection operate only if if reboot both equipment together. Once connected, that is ok.
Thanks, Eric


You need to replace the pypilot.tcz file in /mnt/mmcblk0p2/tce/optional/ with the one downloaded from my site.

You have several possibilities for doing that, the easiest is to copy it using the ssh/scp procotol. If you have a Linux computer, this can be done using something like:
scp pypilot.tcz tc@

The same can be done from a Windows computer but it's a bit more complicated since you need a scp software like WinSCP

the sv stop and starting pypilot manually worked! I then did an sv start and the response was:

tc@pypilot:~$ sudo sv start pypilot
ok: run: pypilot: (pid 3970) 1s, normally down

could it be that it (for some reason) normally doesn't start?

(btw: I'm leaving my boat now, so I can't re-image the pi, but since I have a VPN running from my boat to my home, I can test or send anything)
Hi Stelian, thanks for your help. So, I have successfully, I think, changed the pypilot.tcz file. But what is the way to check the version of this file?
Difficult to said that there is a change in the behavior of the SignalK connection. Some restarting are succesful, some other less. I have to make some other test to give more precise information.
By the way, I have a question already posted on this forum about OpenPlotter Pypilot that is maybe in relation with this issue. To be able to run the Pypilot services remotely from Openplotter, I have installed Openplotter Pypilot but not activated it. During the starting of OP, I got a warning related to this OP Pypilot access request that I deny in SignalK security. I am afraid of a conflict, but did is my configuration the right one to get these remote services available (mainly interesting for pypilot_scope?
@hans-martijn and @Erickalon: Ok, so restarting works (the "normally down" is there because you did a sv stop before).

One thing which could explain the wrong behaviour on start is that signalk requires some python modules which are loaded later during the boot.

Try this:
- log to the tinypilot using ssh
- type 'nano /opt/'
- in the editor, find the line "chpst -utc tce-load -is $PYTHON-urllib3 $PYTHON-chardet $PYTHON-certifi $PYTHON-idna $PYTHON-requests $PYTHON-websocket" and move it from where it is in the file (line 143) to line 80, just above "sv u pypilot"
- save the file, exit the editor
- type 'sudo -b'
- type 'reboot'

@Erikalon : I'm not familiar with OP, but I think that OpenPlotter Pypilot means running the pypilot code on the same computer as OP (not on its dedicated raspberry pi). This is mainly for users who do not use tinypilot but have a single Raspberry PI with a pypilot hat, and which is used as a plotter and a pilot at the same time. This is not your case, so you do not need OP pypilot activated.
@Stelian, I have make the modification and that works. Congratulation ! I will make some trials to assess the result.

For OP Pypilot, the first intention is to operate the pilot on the OpenPlotter Raspberry with a hat or something equivalent, but it was noticed by Ironman in its Pypilot workbook that it was possible to run the Pypilot services remotely. Unfortunately, the way to get it is not very clear. maybe somebody using OpenPlotter and Tinypilot will be able to give me some clarification on the matter.

A new feedback now, I have noticed that the changing mode buttons doesn't work on the web control.

after a reboot pypilot didn't send anything to signalk, after stopping and starting the pypilot service it did. Should I try to set the start of pypilot to a later point in the
@Erikalon and @hans-martijn : your reports are conflicting... Please double check your modifications... Did you do all the steps including the 'sudo -b' step (without this one the changes to /opt/ are not persistent and will revert back on reboot)

Can I have the logs on boot (from /var/log/pypilot/current) when it does not connect to pypilot server ?

@Erikalon : regarding "running the pypilot services remotely" I think this has something to do with the fact that you can run the pypilot services on tinypilot, but still run some utilities (like the scope, or the calibration etc) on OP, and those utilities will run locally while talking to the remote tinypilot. You can do this by specifying the IP address of the tinypilot as an argument to the tool: like in

Finally, regarding "changing mode buttons doesn't work on the web control" this is probably for Sean...
Hi Stelian, on my side, I confirm that I have correctly run and that Signalk connection works fine on my equipment. I have now put back the Sean's 0.40 release and I got the lack of mode choice on RF control and the web control issue. Sean said me 3 days ago he has fixed some questions on on files available on Github but I don't know how to use these files to update my SD card.
The remote use of the pypilot services seems not possible without installing pypilot on the OP Raspi, but maybe did there is a way to get the services without a complete installation.
The pypilot.tcz I built and made available here includes the latest changes in GitHub by Sean.

As for pypilot + OpenPlotter, I suppose it is possible to install pypilot on OpenPlotter but NOT launch it...
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19