OpenMarine

Full Version: New Py Zero 2 W is Out!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
Can you reproduce the problem easily? If so, try to get the output log from pypilot it probably gives clues to what is going wrong.
Hi Sean, I will try to do it. Many thanks.
In addition, the web interface works well with Chrome on my laptop and on my
Android tablet, but not with Firefox on my laptop (on the configuration tab, the entry for LCD keypads and remotes configuration doesn't appear and on the command tab, the mode choice is not operating).
So , there is the log, hoping that I use the right process. Sorry, I don't have found how to send an attachment, I have probably to dig a little in the forum.

tc@pypilot:~$ pypilot
autopilot start 665.390284
world magnetic model not available
ERROR loading wind.py cannot import name 'HeadingOffset' from partially initialized module 'pypilot.autopilot' (most likely due to a circular import) (/usr/local/lib/python3.8/site-packages/pypilot/autopilot.py) cannot import name 'HeadingOffset' from partially initialized module 'pypilot.autopilot' (most likely due to a circular import) (/usr/local/lib/python3.8/site-packages/pypilot/autopilot.py)
imu process 5386
made imu process realtime
Using settings file RTIMULib.ini
Settings file not found. Using defaults and creating settings file
Detected MPU9250/MPU9255 at standard address
Using fusion algorithm Kalman STATE4
IMU Name: MPU-925x
min/max compass calibration not in use
Using ellipsoid compass calibration
Using accel calibration
MPU-925x init complete
nmea process 5391
listening on port 20220 for nmea connections
IMU all sensor axes verified
gps process 5394
loading servo calibration /home/tc/.pypilot/servocalibration
WARNING: using default servo calibration!!
ap mode set compass
Available Pilots: ['basic', 'absolute']
warning: failed to open special file /dev/watchdog0 for writing
cannot stroke the watchdog
pypilotinit complete 668.752454
servo probe ('/dev/ttyAMA0', 38400) 668.784515
server/client is running too _slowly_ 0.06447300000002087
pypilotServer process 5396
gpsd connected
GPSD devices []
load file /home/tc/.pypilot/pypilot.conf
load file /home/tc/.pypilot/pypilot.conf
server setup has 6 pipes
imu rate set to rate 20
too long write pipe 0.0773320198059082 pypilotServer pipe3[1] 26
setting initial gyro bias [0.907, -1.032, 1.675]
ap mode set compass
server add socket ('127.0.0.1', 54864)
server add socket ('127.0.0.1', 54866)
imu rate set to rate 20
server add socket ('10.10.10.1', 50912)
server/client is running too _slowly_ 0.04889300000002095
too long write pipe 0.06901025772094727 pypilotServer pipe0[1] 33
servo probe ('/dev/ttyAMA0', 38400) 674.681146
server/client is running too _slowly_ 0.9432299999999714
autopilot iteration running too slow 0.9604079999999158
signalk process 5393
signalkread token eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJkZXZpY2UiOiJweXBpbG90LTUxNzA1MzQ0NDAxIiwiaWF0IjoxNjgxNzIxMjc4LCJleHAiOjE3MTMyNzg4Nzh9.8JRlphXIwINkpdaREzmBoG6oJ6ieHz4Dg6a9GGw-Djw
server/client is running too _slowly_ 0.049502999999958774
autopilot iteration running too slow 0.05587900000000445
servo probe ('/dev/ttyAMA0', 38400) 678.758189
nmea client failed to connect 10.10.10.167:10110
server/client is running too _slowly_ 0.04718200000002071
autopilot iteration running too slow 0.05503199999998287
servo probe ('/dev/ttyAMA0', 38400) 683.817484
zeroconf addresses ['10.10.10.167', '10.10.10.167', '192.168.14.1', '127.0.0.1'] 4
server/client is running too _slowly_ 0.04861299999993207
autopilot iteration running too slow 0.054923999999914486
zeroconf exception:
servo probe ('/dev/ttyAMA0', 38400) 688.859767
server/client is running too _slowly_ 0.044723999999973785
autopilot iteration running too slow 0.05084599999997863
servo probe ('/dev/ttyAMA0', 38400) 692.938687
autopilot iteration running too slow 0.050579999999968095
gps filter process 5395
servo probe ('/dev/ttyAMA0', 38400) 697.993934
server/client is running too _slowly_ 0.05094700000006469
autopilot iteration running too slow 0.059145000000057735
servo probe ('/dev/ttyAMA0', 38400) 703.01118
server/client is running too _slowly_ 0.044236999999952786
autopilot iteration running too slow 0.050807999999960884
servo probe ('/dev/ttyAMA0', 38400) 707.087758
server/client is running too _slowly_ 0.04425800000001345
autopilot iteration running too slow 0.05084199999998873
servo probe ('/dev/ttyAMA0', 38400) 712.145295
server/client is running too _slowly_ 0.04912699999999859
autopilot iteration running too slow 0.05765099999996437
servo probe ('/dev/ttyAMA0', 38400) 717.161967
servo probe ('/dev/ttyAMA0', 38400) 721.223531
read imu running too _slowly_ 0.04027299999995648 0.05
servo probe ('/dev/ttyAMA0', 38400) 726.311259
server/client is running too _slowly_ 0.04440700000009201
autopilot iteration running too slow 0.05099900000004709
servo probe ('/dev/ttyAMA0', 38400) 731.314646
calibration loaded, starting 5385
server/client is running too _slowly_ 0.04970600000001468
autopilot iteration running too slow 0.061622999999940475
servo probe ('/dev/ttyAMA0', 38400) 735.408383
warning update 0.9910599093854882
warning update 0.9910992835388258
warning update 0.9907141384004037
warning update 0.9910232662664232
warning update 0.9911482924919279
servo probe ('/dev/ttyAMA0', 38400) 740.499135
warning update 0.9912211238744909
warning update 0.9909421922455752
warning update 0.9915005711688917
server/client is running too _slowly_ 0.05103200000007746
autopilot iteration running too slow 0.06104100000004564
warning update 0.9909427589590374
servo probe ('/dev/ttyAMA0', 38400) 745.520967
warning update 0.9909374124424232
warning update 0.9911653811878294
warning update 0.9909721010704382
warning update 0.9910081135934318
autopilot iteration running too slow 0.050240000000030705
servo probe ('/dev/ttyAMA0', 38400) 749.599474
warning update 0.9913436636313193
warning update 0.9911876857363432
warning update 0.9911238273939099
warning update 0.9910175920368218
warning update 0.990759323593411
servo probe ('/dev/ttyAMA0', 38400) 754.687994
warning update 0.9912006717751334
warning update 0.9913283296235907
warning update 0.9912760054396375
warning update 0.9912326211669297
server/client is running too _slowly_ 0.05084199999998873
autopilot iteration running too slow 0.0574100000000044
warning update 0.9908272394826717
servo probe ('/dev/ttyAMA0', 38400) 759.715652
warning update 0.9911579193721607
warning update 0.9911402654293727
warning update 0.9911246473248424
warning update 0.9909309464644029
autopilot iteration running too slow 0.05561499999998887
servo probe ('/dev/ttyAMA0', 38400) 763.805198
warning update 0.991186235197068
warning update 0.9910072781597861
warning update 0.9910411520894243
warning update 0.9911261421852325
servo probe ('/dev/ttyAMA0', 38400) 768.900243
warning update 0.9913978690549162
warning update 0.9910646404824655
warning update 0.9913453642699209
warning update 0.9913557498037129
warning update 0.9909028313767896
servo probe ('/dev/ttyAMA0', 38400) 773.939509
warning update 0.9910460607310885
warning update 0.9912820428854028
warning update 0.9913600902044334
warning update 0.9912835241696967
server/client is running too _slowly_ 0.044265999999993255
autopilot iteration running too slow 0.05272000000002208
servo probe ('/dev/ttyAMA0', 38400) 778.018806
warning update 0.9913690954032987
warning update 0.9907744710934915
warning update 0.9910947985971914
warning update 0.9909349389911412
server/client is running too _slowly_ 0.048725999999987835
autopilot iteration running too slow 0.055195000000026084
warning update 0.9905737492893065
servo probe ('/dev/ttyAMA0', 38400) 783.098738
warning update 0.9913634065610479
warning update 0.9911274949568275
warning update 0.9910260750273822
warning update 0.991266856428007
server/client is running too _slowly_ 0.041556999999897926
warning update 0.9912050790593957
servo probe ('/dev/ttyAMA0', 38400) 788.137243
warning update 0.9914383248728019
warning update 0.9907315934111938
warning update 0.9912444081018669
load file /home/tc/.pypilot/pypilot.conf
server/client is running too _slowly_ 0.04720599999996011
autopilot iteration running too slow 0.05550299999993058
servo probe ('/dev/ttyAMA0', 38400) 792.220886
warning update 0.9912039920101569
warning update 0.9912637352589061
Traceback (most recent call last):

^Cclosing autopilot
I have a suggestion (as a user that has not to make the job...). When the pilot is inactive, if I activate one of the mode by the RF remote controller, the pilot is activated. To inactivate the pilot, I have to press the auto button. If the inactivation was possible by pressing the same button, it would be possible to save a button on this controller. But that's maybe not a so good idea, did I forget some issue with this behavior ?
Hi Erickalon,

I see this:
zeroconf addresses ['10.10.10.167', '10.10.10.167', '192.168.14.1', '127.0.0.1']

This means you run in Master+Managed mode.

Can you please try with the network set to AP or client mode (either one of them will do, just not both).

I did saw some strange things happening with the Master+Managed mode enabled, and I'm not sure the cause is in the tinypilot networking scripts or some kind of network loop...

later edit: I remember now that you are using ethernet, so 10.10.10.167 is probably your ethernet address not the client mode wifi address. So my comment above does not apply. Still, I believe your problem could be caused by some network configuration issue
@hans-martijn: new pypilot build at https://www.popies.net/pypilot/unstable/pypilot.tcz which should fix the rudder signalk issues.

Bugfix has been submitted in github : https://github.com/pypilot/pypilot/pull/197
Hi Stelian, my issue is probably linked to my special network configuration with eth0 (I confirm 10.10.10.167). I am not familiar with the network configuration but I am quite sure that my configuration is not very clean but as it's working fine once connected, I have not dig further. Some help to make a better configuration would be welcome but I am conscious that my aim to get a linked connection is not widely shared.
Despite the question of re-connection, the behavior of this release seems good, once connected the link is stable.
Practically, I shut off the wifi on both equipment if I don't need it. I can restart easily by the terminal as soon that I need it, to use my tablet with VNC for example, that the reason for me to use client and AP mode on both equipment, but there is probably a better way to get this result.
I will make a sea trial tomorrow and give you my observations.

I just have made a trial with the Tinypilot in client mode only, the re-connection seems really better. Thanks a lot for your analysis and suggestion.
Hi stelian, my first trial at sea with the new configuration has been successful. I t was also a test for some modification of my homemade servomotor ans this mechanical part was working fine too. I got some issue with erratic disconnection of the Davis anemometer but I think that I have to improve the USB port arrangement on the OpenPlotter Raspberry, I am using a quite old hub not externally supplied that is probably not the best choice. Despite this disconnections the wind mode works fine.
Thanks for the feedback !
(2023-04-20, 07:54 AM)stelian Wrote: [ -> ]Thanks for the feedback !

Hi Stelian, it's possible to have the latest firmware updated (with windows I wouldn't know how to do the updates you indicated).
 
The ideal would be to be able to do updates via the web like @onno did (https://pcnautic.gitbook.io/autopilot/be...re-upgrade).

 Ciao and good wind, always!  Cool
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19