OpenMarine

Full Version: OpenPlotter 3 roadmap
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
After installing Openplotter 3 and Opencpn 5.6 flatpak via Openplotter 3, Opencpn does not start.

also if I try it via the tereminal :   flatpak run org.opencpn.OpenCPN 

invalid MIT-MAGIC-COOKIE-1 key15:22:44: Error: Unable to initialize GTK+, is DISPLAY set properly?


In the Check system app I see the following error:

Checking OpenCPN... | running |  | FP fullscreen autostart enabled

 ↳Unable to read OpenCPN FP configuration





What could be causing this problem ?
Hi,

I have installed Openplotter 3 and from there installed OpenCpn 5.6 Flatpak

When I start it through open plotter or via terminal (flatpak run org.opencpn.OpenCPN) I get the following response : 

Invalid MIT-MAGIC-COOKIE-1 key15:22:44: Error: Unable to initialize GTK+, is DISPLAY set properly?

If I do a startup check, I get : 

Checking OpenCPN... | running |  | FP fullscreen autostart enabled
 ↳Unable to read OpenCPN FP configuration


So the problem is OpenCpn does not start up at the screen, what could be the cause of this problem ?
have you changed the user name of your system after installing opencpn with flatpak?
Are you in a headless system?

Try this:

sudo flatpak run org.opencpn.OpenCPN

or try to uninstall and reinstall.
Do you have the Avnav enabled? OpenCPN FP & Avnav do not seem to play together well. OpenCPN FP will not open with Avnav enabled.

Updated Avnav a few days back and it auto enabled on me. It had me chasing my tail for a bit.
(2022-04-25, 12:14 AM)Opie91 Wrote: [ -> ]Do you have the Avnav enabled? OpenCPN FP & Avnav do not seem to play together well. OpenCPN FP will not open with Avnav enabled.

Updated Avnav a few days back and it auto enabled on me. It had me chasing my tail for a bit.

would be interesting to get some more info on that.
Normally they should not interfere at all.
Hey,

I installed OpenPlotter 3 on my raspi 4. After some configurations, I can't open the openplotter-network. This is the result Trace:

openplotter-network

Traceback (most recent call last):
  File "/usr/bin/openplotter-network", line 11, in <module>
    load_entry_point('openplotterNetwork==3.1.2', 'console_scripts', 'openplotter-network')()
  File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 975, in main
    MyFrame().Show()
  File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 85, in __init__
    self.pageClient()
  File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 863, in pageClient
    self.read_wlan()
  File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 899, in read_wlan
    self.client_bitRate1.SetValue(self.find_line_split_set2(wlan_info,"Rate","=",1).split("   ")[0])
AttributeError: 'NoneType' object has no attribute 'split'
(2022-04-25, 01:06 PM)wellenvogel Wrote: [ -> ]
(2022-04-25, 12:14 AM)Opie91 Wrote: [ -> ]Do you have the Avnav enabled? OpenCPN FP & Avnav do not seem to play together well. OpenCPN FP will not open with Avnav enabled.

Updated Avnav a few days back and it auto enabled on me. It had me chasing my tail for a bit.

would be interesting to get some more info on that.
Normally they should not interfere at all.

Do not know what to say. Just it has been my experience that they OpenCPN FP will not open with the Avnav service running.

I have turned Avnav service on/off and it is definitely repeatable.
(2022-04-26, 05:13 PM)Opie91 Wrote: [ -> ]
(2022-04-25, 01:06 PM)wellenvogel Wrote: [ -> ]
(2022-04-25, 12:14 AM)Opie91 Wrote: [ -> ]Do you have the Avnav enabled? OpenCPN FP & Avnav do not seem to play together well. OpenCPN FP will not open with Avnav enabled.

Updated Avnav a few days back and it auto enabled on me. It had me chasing my tail for a bit.

would be interesting to get some more info on that.
Normally they should not interfere at all.

Do not know what to say. Just it has been my experience that they OpenCPN FP will not open with the Avnav service running.

I have turned Avnav service on/off and it is definitely repeatable.

Do you have some logs (e.g. OpenCPN log)?
And what is the error? 
Does OpenCPN not come up? Does it crash?
Is it unable to display some charts?
Can you try to start from the command line?
(2022-04-16, 02:06 PM)Hobo Wrote: [ -> ]Hi,

I have installed Openplotter 3 and from there installed OpenCpn 5.6 Flatpak

When I start it through open plotter or via terminal (flatpak run org.opencpn.OpenCPN) I get the following response : 

Invalid MIT-MAGIC-COOKIE-1 key15:22:44: Error: Unable to initialize GTK+, is DISPLAY set properly?

If I do a startup check, I get : 

Checking OpenCPN... | running |  | FP fullscreen autostart enabled
 ↳Unable to read OpenCPN FP configuration


So the problem is OpenCpn does not start up at the screen, what could be the cause of this problem ?

I have been able to reproduce this error. It happens when using OpenPlotter headless. This is my error:

Code:
(opencpn:2): Gdk-ERROR **: 18:54:58.144: The program 'opencpn' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
 (Details: serial 380 error_code 10 request_code 130 (MIT-SHM) minor_code 1)
 (Note to programmers: normally, X errors are reported asynchronously;
  that is, you will receive the error a while after causing it.
  To debug your program, run it with the GDK_SYNCHRONIZE environment
  variable to change this behavior. You can then get a meaningful
  backtrace from your debugger if you break on the gdk_x_error() function.)

I have reported this to OpenCPN devs, thanks for notifying: https://github.com/OpenCPN/OpenCPN/issues/2628
(2022-04-26, 12:34 PM)jtaraskin Wrote: [ -> ]Hey,

I installed OpenPlotter 3 on my raspi 4. After some configurations, I can't open the openplotter-network. This is the result Trace:

openplotter-network

Traceback (most recent call last):
  File "/usr/bin/openplotter-network", line 11, in <module>
    load_entry_point('openplotterNetwork==3.1.2', 'console_scripts', 'openplotter-network')()
  File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 975, in main
    MyFrame().Show()
  File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 85, in __init__
    self.pageClient()
  File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 863, in pageClient
    self.read_wlan()
  File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 899, in read_wlan
    self.client_bitRate1.SetValue(self.find_line_split_set2(wlan_info,"Rate","=",1).split("   ")[0])
AttributeError: 'NoneType' object has no attribute 'split'

what configurations? manual network configurations or configurations through the openplotter interface?

Try uninstalling openplotter-network app from settings and reinstalling again.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35