OpenMarine

Full Version: OpenPlotter 3 roadmap
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
(2022-02-06, 06:22 PM)Sailoog Wrote: [ -> ]I can not update from signal k server:

Feb 06 17:14:28 POST /skServer/appstore/install/signalk-server/1.41.1 404 1375.630 ms - 49

Reinstalling SK server from scratch using npm works.

Sorry about that, I broke the update feature in 1.41.0 and 1.41.1, should be fixed in 1.41.2.
Thanks for the quick fix tkurki.

I have reinstalled all my instances, anyone still with Signal K server 1.41.0 to test?
(2022-02-08, 09:09 PM)Sailoog Wrote: [ -> ]Thanks for the quick fix tkurki.

I have reinstalled all my instances, anyone still with Signal K server 1.41.0 to test?

I have OpenPlotter with SignalK Server 1.41.0. Should I run "sudo npm install -g signalk-server" or is it a different process in OpenPlotter?
You should try to do it from the Signal K administrator:

http://localhost:3000/admin/#/serverConf...ion/update
(2022-02-08, 09:34 PM)Sailoog Wrote: [ -> ]You should try to do it from the Signal K administrator:

http://localhost:3000/admin/#/serverConf...ion/update


I am running 1.41.0 and still cannot update to 1.41.2 fromĀ http://localhost:3000/admin/#/serverConf...ion/update

Doing the same as when trying to update to 1.41.1
sorry, that makes sense, if 1.41.0 is broken you will not be able to update.

There are 2 options to move on:

- Go to OpenPlotter Signal K installer app and press "Reinstall Signal K". You will lose all settings.
- Open a terminal and enter "sudo npm install -g signalk-server". You will keep your settings.
Unfortunately it doesn't seem to work. When you click on the "Are you sure" prompt, it simply redirects to the Appstore Updates page without installing anything.

I've tried on 2 systems, one running OP2 and one running OP3, and they both have the same behaviour.

[attachment=1705]
[attachment=1704]
(2022-02-08, 09:58 PM)TVR Wrote: [ -> ]Unfortunately it doesn't seem to work. When you click on the "Are you sure" prompt, it simply redirects to the Appstore Updates page without instlaling anything.

I've tried on 2 systems, one running OP2 and one running OP3, and they both have the same behaviour.

Yes, sorry, see my previous post.
(2022-02-08, 09:57 PM)Sailoog Wrote: [ -> ]There are 2 options to move on:

- Go to OpenPlotter Signal K installer app and press "Reinstall Signal K". You will lose all settings.
- Open a terminal and enter "sudo npm install -g signalk-server". You will keep your settings.


Thanks, that worked using option 2.
For what it's worth, signal k and opencpn talking with the alpha version of the 64bit installed today. I have the PiCAN hat, but the pi isn't at the boat yet so, not tied to anything beside the USB GPS.

The opencpn installer was being a bit fussy with versioning before it allowed me to install openCPN, but basics are all running great.

Anything in particular I should be poking around in with to help?

Edit: i had been having troubles with the USB GPS and the node versions when I installed node-red. I saw a reference to that error being resolved upthread somewhere. I'll install node red in the next few days and check.

Thanks guys!!!
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35