OpenMarine

Full Version: OpenPlotter 3 roadmap
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
System check shows signal k not running

I ran signal k installer and re-installed

This may be expected?

(2022-05-21, 05:53 PM)Sailoog Wrote: [ -> ]OK, that sounds like a progress Smile

Today I will publish new versions for apps using sources (dashboards, signal k, opencpn, settings). Now you should not have problems installing openplotter in any Debian derivative and any Ubuntu derivative.

Thanks Sailoog, glad I can contribute Smile
New versions for settings, dashboards, signal k and opencpn fixing errors.

To avoid problems with old versions first update settings and click on "add sources", then update the rest of apps.
Sailoog,

Thanks for Turing round these releases so quickly.

Update sequence completed as suggested.

Check system results:

Checking NTP server... | running
Checking Power off management... | disabled
Checking Shutdown management... | disabled
Checking OpenPlotter autostart... | enabled
Checking rescue mode...
↳enabled
Checking debugging mode... | disabled
Checking system log file size... | System log file size: 1.6 MB
Checking OpenPlotter packages source... | added
Starting MAIANA transponder...
Checking MAIANA transponder... | not running
↳There is no MAIANA device defined
The access request must be aproved with read/write permission in Signal K administrator.
Starting Dashboards...
Starting Notifications...
Checking Notifications... | Access to Signal K server validated
↳Notifications is in rescue mode
Checking serial connections alias... | All your serial connections have an assigned alias
Checking Signal K server... | running
Checking serial connections conflicts... | no conflicts
Checking network connections conflicts... | no conflicts
Checking GPIO conflicts... | no conflicts
STARTUP FINISHED

No further testing today.
(2022-05-21, 05:49 PM)Paul M Wrote: [ -> ]I get the following response when adding sources:

OpenPlotter packages source already exists
free-x packages source already exists


Pressing refresh takes a while but gives the expected result. (50 seconds)

I downloaded OP3 starting-64 today. I had the same issue, and solved it thanks to Sailoog above suggestion . Rest of the
aps is being installed right now, Ill come back at the soonest with 1st impressions Big Grin
The problem I had with influx was my mistake, I hadn’t realised that the signal k key needs to be prefixed with ‘self.’ Data now being stored in the influx db 2 bucket.

I’ve begun looking at the network (Wi-Fi) configuration with rpi os 64 and op3.

I pre-configured the settings using raspberry pi imager v1.7.2 hostname, ssh password, ssid, password etc.and it worked ok.

I added a second Wi-Fi (usb dongle) on my pi4. Intending to use it as a hotspot

a) using a ralink device

- the ssid and password were mirrored from the main Wi-Fi on the pi and

- op3 network app opened

b) using a different Wi-Fi dongle (realtek)

- the dongle remained unassociated

- op3 network app failed to start.

Running Openplotter-network gives the following response:


pi@raspberrypi:~ $ openplotter-network
Traceback (most recent call last):
File "/usr/bin/openplotter-network", line 11, in <module>
load_entry_point('openplotterNetwork==3.1.2', 'console_scripts', 'openplotter-network')()
File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 975, in main
MyFrame().Show()
File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 85, in __init__
self.pageClient()
File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 863, in pageClient
self.read_wlan()
File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 899, in read_wlan
self.client_bitRate1.SetValue(self.find_line_split_set2(wlan_info,"Rate","=",1).split(" ")[0])
AttributeError: 'NoneType' object has no attribute 'split'


It may be that the Realtek is not supported, I did have problems with it on the buster release.
Hi,
I'm running OpenPlotter 3 64 bit on my headless RPI 4 running the last bullseye 64 bit and I still have some issues with OpenCPN FP:
It still can't open (Error: Unable to initialize GTK+, is DISPLAY set properly?) when avnav-ocharts plugin is enabled.
And when I disable it or when Avnav is not running, OpenCPN FP opens but it is very slow and I noticed several bugs:
- No matter what I do, I always have the "Unable to read OpenCPN FP configuration" in Check system.
- When I type "sudo flatpak run org.opencpn.OpenCPN" I have the error: app/org.opencpn.OpenCPN/aarch64/master not installed
- When I type "flatpak run org.opencpn.OpenCPN" (without sudo), it opens but I have the bug report:
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug
- When it opens, it always starts acting like it had previously crashed (asking if I want to disable plugins), it starts with a 0x0 window size unless I closed it in maximized or in full screen mode. It does it too with the Options window or the Object query window.
- When I open the Options windows, I have a lot of these recurring messages:
(opencpn:2): Gtk-CRITICAL **: 16:58:59.917: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkScrollbar
(opencpn:2): Gtk-CRITICAL **: 16:58:59.918: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkScrollbar
(opencpn:2): Gtk-CRITICAL **: 16:59:00.290: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkScrollbar
(opencpn:2): Gtk-WARNING **: 16:59:00.291: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node notebook, owner GtkNotebook)
(opencpn:2): Gtk-WARNING **: 16:59:00.291: Negative content height -1 (allocation 1, extents 1x1) while allocating gadget (node notebook, owner GtkNotebook)
(opencpn:2): Gtk-CRITICAL **: 16:59:00.291: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkNotebook
(opencpn:2): Gtk-CRITICAL **: 16:59:00.292: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkNotebook
(opencpn:2): Gtk-WARNING **: 16:59:00.292 Negative content width -2 (allocation 0, extents 1x1) while allocating gadget (node header, owner GtkNotebook)
(opencpn:2): Gtk-CRITICAL **: 16:59:00.292: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkNotebook
(opencpn:2): Gtk-WARNING **: 16:59:00.316 Negative content width -33 (allocation 1, extents 17x17) while allocating gadget (node button, owner GtkButton)
(opencpn:2): Gtk-WARNING **: 16:59:00.316 Negative content height -9 (allocation 1, extents 5x5) while allocating gadget (node button, owner GtkButton)
...
Let me know if there is anything I can do to help.
Thank you again for your incredible work.
Best regards.
Romain
(2022-05-22, 07:24 PM)Paul M Wrote: [ -> ]The problem I had with influx was my mistake, I hadn’t realised that the signal k key needs to be prefixed with ‘self.’ Data now being stored in the influx db 2 bucket.

I’ve begun looking at the network (Wi-Fi) configuration with rpi os 64 and op3.

I pre-configured the settings using raspberry pi imager v1.7.2 hostname, ssh password, ssid, password etc.and it worked ok.

I added a second Wi-Fi (usb dongle) on my pi4. Intending to use it as a hotspot

a) using a ralink device

- the ssid and password were mirrored from the main Wi-Fi on the pi and

- op3 network app opened

b) using a different  Wi-Fi dongle (realtek)

- the dongle remained unassociated

- op3 network app failed to start.

Running Openplotter-network gives the following response:


pi@raspberrypi:~ $ openplotter-network
Traceback (most recent call last):
 File "/usr/bin/openplotter-network", line 11, in <module>
   load_entry_point('openplotterNetwork==3.1.2', 'console_scripts', 'openplotter-network')()
 File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 975, in main
   MyFrame().Show()
 File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 85, in __init__
   self.pageClient()
 File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 863, in pageClient
   self.read_wlan()
 File "/usr/lib/python3/dist-packages/openplotterNetwork/openplotterNetwork.py", line 899, in read_wlan
   self.client_bitRate1.SetValue(self.find_line_split_set2(wlan_info,"Rate","=",1).split("   ")[0])
AttributeError: 'NoneType' object has no attribute 'split'


It may be that the Realtek is not supported, I did have problems with it on the buster release.

I got the same problem.
Paul M and jtaraskin, could you please put here the chipset models of your devices? usually you can know that opening a terminal an typing lsusb after pluging in the device.

This is obviously a bug, we can not break the app when non compatibles devices are connected, or maybe they are compatible and there is another problem, let's see.

EDIT: please send me also the output of iwconfig command when the devices are connected.
(2022-05-22, 10:13 PM)romton Wrote: [ -> ]Hi,
I'm running OpenPlotter 3 64 bit on my headless RPI 4 running the last bullseye 64 bit and I still have some issues with OpenCPN FP:
It still can't open (Error: Unable to initialize GTK+, is DISPLAY set properly?) when avnav-ocharts plugin is enabled.
And when I disable it or when Avnav is not running, OpenCPN FP opens but it is very slow and I noticed several bugs:
- No matter what I do, I always have the "Unable to read OpenCPN FP configuration" in Check system.
- When I type "sudo flatpak run org.opencpn.OpenCPN" I have the error: app/org.opencpn.OpenCPN/aarch64/master not installed
- When I type "flatpak run org.opencpn.OpenCPN" (without sudo), it opens but I have the bug report:
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug
- When it opens, it always starts acting like it had previously crashed (asking if I want to disable plugins), it starts with a 0x0 window size unless I closed it in maximized or in full screen mode. It does it too with the Options window or the Object query window.
- When I open the Options windows, I have a lot of these recurring messages:
(opencpn:2): Gtk-CRITICAL **: 16:58:59.917: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkScrollbar
(opencpn:2): Gtk-CRITICAL **: 16:58:59.918: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkScrollbar
(opencpn:2): Gtk-CRITICAL **: 16:59:00.290: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkScrollbar
(opencpn:2): Gtk-WARNING **: 16:59:00.291: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node notebook, owner GtkNotebook)
(opencpn:2): Gtk-WARNING **: 16:59:00.291: Negative content height -1 (allocation 1, extents 1x1) while allocating gadget (node notebook, owner GtkNotebook)
(opencpn:2): Gtk-CRITICAL **: 16:59:00.291: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkNotebook
(opencpn:2): Gtk-CRITICAL **: 16:59:00.292: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkNotebook
(opencpn:2): Gtk-WARNING **: 16:59:00.292 Negative content width -2 (allocation 0, extents 1x1) while allocating gadget (node header, owner GtkNotebook)
(opencpn:2): Gtk-CRITICAL **: 16:59:00.292: gtk_box_gadget_dristribute: assertion 'size >= 0' failed in GtkNotebook
(opencpn:2): Gtk-WARNING **: 16:59:00.316 Negative content width -33 (allocation 1, extents 17x17) while allocating gadget (node button, owner GtkButton)
(opencpn:2): Gtk-WARNING **: 16:59:00.316 Negative content height -9 (allocation 1, extents 5x5) while allocating gadget (node button, owner GtkButton)
...
Let me know if there is anything I can do to help.
Thank you again for your incredible work.
Best regards.
Romain

Just ignore these errors:

In pixman_region32_init_rect: Invalid rectangle passed

Set a breakpoint on '_pixman_log_error' to debug

(opencpn:2): Gtk-CRITICAL **...

Those are non critical and expected issues and do not affect performance.

I have opened a new thread to try to fix the Avnav issue: https://forum.openmarine.net/showthread.php?tid=4063
Lsusb and iwconfig Realtek dongle:

pi@raspberrypi:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 09da:024f A4Tech Co., Ltd. RF Receiver and G6-20D Wireless Optical Mouse
Bus 001 Device 004: ID 174c:55aa ASMedia Technology Inc. ASM1051E SATA 6Gb/s bridge, ASM1053E SATA 6Gb/s bridge, ASM1153 SATA 3Gb/s bridge, ASM1153E SATA 6Gb/s bridge
Bus 001 Device 003: ID 1546:01a7 U-Blox AG [u-blox 7]
Bus 001 Device 006: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@raspberrypi:~ $

i@raspberrypi:~ $ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:"vodafonexxxxxx”
Mode:Managed Frequency:5.5 GHz Access Point: D6:35:1D:07:05:6B
Bit Rate=433.3 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=70/70 Signal level=-38 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:0 Missed beacon:0

wlan1 unassociated ESSID:"" Nickname:"<WIFI@REALTEK>"
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35