OpenMarine

Full Version: OpenPlotter 3 roadmap
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
(2022-04-26, 08:06 PM)jtaraskin Wrote: [ -> ]
(2022-04-26, 08:01 PM)Sailoog Wrote: [ -> ]What is the "internal wlan Adapter"? the Ethernet port of your Raspberry?

Before reinstalling you should uninstall, you did that?

After reinstalling try again without any external device connected to your Raspberry.

Internal Wireless Adapter of the Raspberry Pi. I have a WLAN Dongle from Edimax. And I try to set up the internal Adapter as an Access Point for my Tablet/Phon etc. and the second one (Edimax) for the communication with the internet. The Ethernet port is also as a "test" in my network. I reinstall it now and reject all my external devices and give you informations.

Now I can start openplotter-network. Do I have to insert the Edimax WLAN Adapter before I configure the AP function with the internal WLAN Adapter, or first internal Adapter as AP and then put in the Edimax and connect to the WLAN Network of a Marina, or my Homenetwork?

Now I could find out the behavior. If I insert the WLAN Dongle Edimax, I can't start openplotter-network. After I had configured the AP:

I think your Edimax device could not be supported in this kernel. Do you know the chip set? type lsusb in a terminal to see the chip set
Hi, great feedback for the progress so far. I used to be a java developper and now more in IT management but i love this openplotter product and I would like to contribute in some way. I was able to get a hand on a new ras-pi 4/4G, and trying to move my SD card from my fiend's pi 4/4G to my newly received, i was faced with the "new hardware" problem that forces me to dist-upgrade go to bullseye (which failed).

My main goal is to help you get the pican-m working. I have a testbench with a B&G WS320 and a GPS (nmea2000) and a BME280 attached to the I2C of the pican-m. So If I can do anything to get it to work I will be happy, right now, it randomly freezes if I try to activate SPI or I2C. I tried the 64bit starter of version 3.x. 

Regards.
(2022-04-27, 07:39 PM)Sailoog Wrote: [ -> ]
(2022-04-26, 08:06 PM)jtaraskin Wrote: [ -> ]
(2022-04-26, 08:01 PM)Sailoog Wrote: [ -> ]What is the "internal wlan Adapter"? the Ethernet port of your Raspberry?

Before reinstalling you should uninstall, you did that?

After reinstalling try again without any external device connected to your Raspberry.

Internal Wireless Adapter of the Raspberry Pi. I have a WLAN Dongle from Edimax. And I try to set up the internal Adapter as an Access Point for my Tablet/Phon etc. and the second one (Edimax) for the communication with the internet. The Ethernet port is also as a "test" in my network. I reinstall it now and reject all my external devices and give you informations.

Now I can start openplotter-network. Do I have to insert the Edimax WLAN Adapter before I configure the AP function with the internal WLAN Adapter, or first internal Adapter as AP and then put in the Edimax and connect to the WLAN Network of a Marina, or my Homenetwork?

Now I could find out the behavior. If I insert the WLAN Dongle Edimax, I can't start openplotter-network. After I had configured the AP:

I think your Edimax device could not be supported in this kernel. Do you know the chip set? type lsusb in a terminal to see the chip set

This is: Bus 001 Device 003: ID 7392:b811 Edimax Technology Co., Ltd Edimax N150 Adapter

(2022-04-28, 02:31 AM)openmarinebou Wrote: [ -> ]Hi, great feedback for the progress so far. I used to be a java developper and now more in IT management but i love this openplotter product and I would like to contribute in some way. I was able to get a hand on a new ras-pi 4/4G, and trying to move my SD card from my fiend's pi 4/4G to my newly received, i was faced with the "new hardware" problem that forces me to dist-upgrade go to bullseye (which failed).

My main goal is to help you get the pican-m working. I have a testbench with a B&G WS320 and a GPS (nmea2000) and a BME280 attached to the I2C of the pican-m. So If I can do anything to get it to work I will be happy, right now, it randomly freezes if I try to activate SPI or I2C. I tried the 64bit starter of version 3.x. 

Regards.

Yeah pican-m would be nice. I also have this Header, but I use it with Seatalk Raymarine.
(2022-04-28, 02:31 AM)openmarinebou Wrote: [ -> ]Hi, great feedback for the progress so far. I used to be a java developper and now more in IT management but i love this openplotter product and I would like to contribute in some way. I was able to get a hand on a new ras-pi 4/4G, and trying to move my SD card from my fiend's pi 4/4G to my newly received, i was faced with the "new hardware" problem that forces me to dist-upgrade go to bullseye (which failed).

My main goal is to help you get the pican-m working. I have a testbench with a B&G WS320 and a GPS (nmea2000) and a BME280 attached to the I2C of the pican-m. So If I can do anything to get it to work I will be happy, right now, it randomly freezes if I try to activate SPI or I2C. I tried the 64bit starter of version 3.x. 

Regards.

I do not have any pican-m but all the feaures should already work in OpenPlotter 3.

I can not reproduce that issue with SPI or I2C. Is your system up to date?
I just installed OP3 alpha 64 on my rpi4 4gb and want to start some testing.
There is no info on Moitessier hat any more. Am I too early or will Moitessier hat cease to exist?
BTW Sailoog, when is start of beta testing scheduled ?
Please keep us informed and thanks for your great work!!!
Follow the first post of this thread: https://forum.openmarine.net/showthread.php?tid=3878

There is what you are asking for. openplotter-dashboard app will be done this week and the beta process will start soon.
Hello,
I've deployed OP3 image on my RPi 4/4GB. I did not face any issue deploying SignalK and OpenCPN 5.6.2. But I face an issue regarding the plugins : I can see only the 4 default plugins in OpenCPN so I cannot deploy O-Charts. Did anyone faced the same issue ?
(2022-05-03, 11:11 AM)Elzariant Wrote: [ -> ]Hello,
I've deployed OP3 image on my RPi 4/4GB. I did not face any issue deploying SignalK and OpenCPN 5.6.2. But I face an issue regarding the plugins : I can see only the 4 default plugins in OpenCPN so I cannot deploy O-Charts. Did anyone faced the same issue ?
OP3 is working really well for me so far. Congratulations to everyone. I agree that having access to the new O-Charts Plugin would be helpful. I did not see that in the list on page 1?
In OpenPlotter 3 for 64bit you need to install OpenCPN by flatpak to see the plugins.

More info: https://forum.openmarine.net/showthread....9#pid21639
Hello,

I finally arrived to the same conclusion browsing all different version of O-charts plugin from Cloudsmith. The FP package takes much longer to download but it works fine and I retrieved all my plugins. Thanks a lot Sailoog for your work.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35