OpenMarine

Full Version: OpenPlotter 3 roadmap
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
(2022-02-14, 08:57 PM)Sailoog Wrote: [ -> ]type this in a terminal and send me the result:


Code:
cat /sys/firmware/devicetree/base/model

pi@openplotter:~ $ cat /sys/firmware/devicetree/base/model

Raspberry Pi 4 Model B Rev 1.2
The current op-settings is only searching for Rev 1.1 and 1.4

I will add 1.2 on next release, thanks!
(2022-02-08, 09:03 PM)tkurki Wrote: [ -> ]
(2022-02-06, 06:22 PM)Sailoog Wrote: [ -> ]I can not update from signal k server:

Feb 06 17:14:28 POST /skServer/appstore/install/signalk-server/1.41.1 404 1375.630 ms - 49

Reinstalling SK server from scratch using npm works.

Sorry about that, I broke the update feature in 1.41.0 and 1.41.1, should be fixed in 1.41.2.

I think it's broken again!!

I updated to 1.41.3 & now cannot get SignalK in the browser

I'm pretty sure it's running but cannot access it.
(2022-02-16, 04:47 AM)Lazzz Wrote: [ -> ]I think it's broken again!!

I updated to 1.41.3 & now cannot get SignalK in the browser

I'm pretty sure it's running but cannot access it.

Had similar, try deleting cookies & site data on your browser, in chrome >> it;s in settings|security & privicy

chrome://settings/privacy
(2022-02-16, 10:18 AM)PaddyB Wrote: [ -> ]
(2022-02-16, 04:47 AM)Lazzz Wrote: [ -> ]I think it's broken again!!

I updated to 1.41.3 & now cannot get SignalK in the browser

I'm pretty sure it's running but cannot access it.

Had similar, try deleting cookies & site data on your browser, in chrome >> it;s in settings|security & privicy

chrome://settings/privacy


Yeah, thanks Paddy. I didn't really want to do that - Have to re-do my pages in KIP etc again!! 

I think I'll just leave the updates until they've been out for a while & they get sorted.
(2022-02-16, 11:17 AM)Lazzz Wrote: [ -> ]Yeah, thanks Paddy. I didn't really want to do that - Have to re-do my pages in KIP etc again!! 

I just keep a saved version of KIP on the server, just takes a moment to reload in the browser
(2022-02-16, 11:33 AM)PaddyB Wrote: [ -> ]I just keep a saved version of KIP on the server, just takes a moment to reload in the browser

Thanks Paddy - that worked.

I saved them but how do you reload? Do you put the KIP files in the Chromium-browser folder??
(2022-02-06, 05:27 PM)tkurki Wrote: [ -> ]
(2022-02-06, 11:39 AM)Sailoog Wrote: [ -> ]It seems that that error "debug is not defined" is a bug in Signal k server and it will be fixed on next update: https://github.com/SignalK/signalk-server/issues/1386
thanks!

Signal K Server v1.41.1 is published, including a fix for this in module @signalk/streams@2.0.4.

It's probably worth mentioning that SK server's recommended Node.Js version is 16 from SK server version 1.41 onwards. The server has been working with Node 16 for quite some time and still should work with the previously recommended Node 10. But sooner or later you will need to update. Node 10 is also end of life, meaning that it will no longer receive any security updates.

There's a separate help page in SK server for updating to Node 16: https://github.com/SignalK/signalk-serve...Node.js-16

Please note that I don't monitor OP forums. If there's trouble that needs attention from me or other core developers Signal K Slack and/or Github are much better. Then again there's plenty of practical experience in particularly related to SK in OP here, so peer support here is also an option.

OP3 roadmap in the first message in this thread says that update to Node 16 is done already there.

I did try updating to Node 16 and, as stated in your instructions in the link, it did kill my XRUSB0 port to my solar controller. I couldn't get the two to talk again. Baring something else, I'll have to wait for a new way to make that work and will have to hang out at 1.41.0, as it's been very solid for me.

Anything else I need to look at to make it work? I'm most likely missing something.
(2022-02-06, 05:27 PM)tkurki Wrote: [ -> ]Please note that I don't monitor OP forums. If there's trouble that needs attention from me or other core developers Signal K Slack and/or Github are much better. Then again there's plenty of practical experience in particularly related to SK in OP here, so peer support here is also an option.

Maybe you should check in every so often if you are going to keep breaking SK - there are a lot of people here who are not nerds using SK in OpenPlotter!!  Big Grin

Thanks to those here who help non-nerd sailors!!
(2022-02-16, 10:11 PM)Lazzz Wrote: [ -> ]
(2022-02-16, 11:33 AM)PaddyB Wrote: [ -> ]I just keep a saved version of KIP on the server, just takes a moment to reload in the browser

Thanks Paddy - that worked.

I saved them but how do you reload? Do you put the KIP files in the Chromium-browser folder??


Look in settings / configuration >
Save & load from there, I have one saved for laptop & another for a tablet. 
[Image: A6XbqhR.png]

"Maybe you should check in every so often if you are going to keep breaking SK"

Signalk wasn't actually broken, it's just old data in your browser, just delete the old data.

Slack is the place to talk signalk, much better route to talk to the main & app developers >> http://slack-invite.signalk.org/
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35