OpenMarine

Full Version: OpenPlotter 3 roadmap
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35
thanks for the report.

It seems that that error "debug is not defined" is a bug in Signal k server and it will be fixed on next update: https://github.com/SignalK/signalk-server/issues/1386

The amount of available plugins in OpenCPN now depends on the architecture you are and the source you have used to install OpenCPN. For your case (OpenCPN running in 32 bits installed from PPA) you should notify to OpenCPN developers about any missing plugin for that platform and any bug in any plugin like the otcurrent in your case.

thanks!
(2022-02-06, 11:39 AM)Sailoog Wrote: [ -> ]It seems that that error "debug is not defined" is a bug in Signal k server and it will be fixed on next update: https://github.com/SignalK/signalk-server/issues/1386
thanks!

Signal K Server v1.41.1 is published, including a fix for this in module @signalk/streams@2.0.4.

It's probably worth mentioning that SK server's recommended Node.Js version is 16 from SK server version 1.41 onwards. The server has been working with Node 16 for quite some time and still should work with the previously recommended Node 10. But sooner or later you will need to update. Node 10 is also end of life, meaning that it will no longer receive any security updates.

There's a separate help page in SK server for updating to Node 16: https://github.com/SignalK/signalk-serve...Node.js-16

Please note that I don't monitor OP forums. If there's trouble that needs attention from me or other core developers Signal K Slack and/or Github are much better. Then again there's plenty of practical experience in particularly related to SK in OP here, so peer support here is also an option.

OP3 roadmap in the first message in this thread says that update to Node 16 is done already there.
I can not update from signal k server:

Feb 06 17:14:28 POST /skServer/appstore/install/signalk-server/1.41.1 404 1375.630 ms - 49

Reinstalling SK server from scratch using npm works.
OpenPlotter Serial app is done, working on docs for it.

I have published new 32bit and 64 bit alpha images: https://cloud.openmarine.net/s/mxrBi5K7zRj2gDq

Next OpenPlotter CAN app...
(2022-02-06, 09:55 PM)Sailoog Wrote: [ -> ]OpenPlotter Serial app is done, working on docs for it.

I have published new 32bit and 64 bit alpha images: https://cloud.openmarine.net/s/mxrBi5K7zRj2gDq

Next OpenPlotter CAN app...

Great. I was able to install it using the settings app and got the USB GPS up and running no issues. Connection to Signal K all good.

Any issue with installing new apps with the settings app or should we be burning an image each time?

Thanks!
(2022-02-06, 09:55 PM)Sailoog Wrote: [ -> ]OpenPlotter Serial app is done, working on docs for it.

I have published new 32bit and 64 bit alpha images: https://cloud.openmarine.net/s/mxrBi5K7zRj2gDq

Next OpenPlotter CAN app...

Hi Sailoog, I tried the latest version on Pi4 - 2giga also in the 64 bit version. 

All right. It is actually faster and smoother. Good job!

Smile Smile Smile
thanks for testing.

you can install apps from settings, no need to burn a new image but it is recommended. Remember that these are alpha and beta images only for testing and debugging. You must burn a new image when the stable image is released.
I've tried the new Settings app, and it's all working perfectly.

The only thing I've noticed is that the older version had a graphic in the "Devices" tab showing which USB port the device was plugged into. This is missing from the new version, is that deliberate?
(2022-02-07, 07:35 PM)Sailoog Wrote: [ -> ]thanks for testing.

you can install apps from settings, no need to burn a new image but it is recommended. Remember that these are alpha and beta images only for testing and debugging. You must burn a new image when the stable image is released.

Ok, just for testing and new image when stable. Thanks and as always good wind! 


 PS: and it works well with Sean's Pypilot: Small video:

  https://www.youtube.com/watch?v=29Pil3dLFo0   Smile
(2022-02-07, 08:40 PM)TVR Wrote: [ -> ]I've tried the new Settings app, and it's all working perfectly.

The only thing I've noticed is that the older version had a graphic in the "Devices" tab showing which USB port the device was plugged into. This is missing from the new version, is that deliberate?

Not deliberate at all, icons should be there. I can see icons on Raspberry Pi 4 8GB running 64bit. what is your Raspberry model and OpenPlotter version? Do you have any device connected to USB ports?
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35